Can I change Reply to address with Iphone? (Gmail or Yahoo?)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by blackprius06, Jul 13, 2007.

  1. blackprius06 macrumors newbie


    Jul 13, 2007
    After 2 weeks with my 8 gig iphone I love every part of it - except for e-mail. I have had a blackberry for years, so I am faithful that all I need to do is give the iphone sometime and it will become my friend. :) - So with that -

    Anyone have any tips to allow you to change the push yahoo reply to address? I have a account. I am currently forwarding a copy of my office e-mail to my address. It pushes well to the iphone, but if anyone replys it goes to my address and not my office address.

    I have upgraded my account and changed the reply to on Yahoo's mail site, but I can't seem to do this directly on the iPhone.

    Any suggestions? I do know I can check my work e-mail directly as a pop account, but then outgoing mail tends to be a problem as I have to change the outgoing mail server depending on what network I am on. I want to just set it - and forget it. :)

    Many thanks!
  2. d21mike macrumors 68040


    Jul 11, 2007
    Torrance, CA
    Can't change the reply to address

    Here is my workaround for now:
    I also forward my work email to Yahoo Push. However, since I can't change the reply to (or FROM) I use a Mobile Web Mail page to send/reply email. My company uses Godaddy to handle our email and they have a very nice Mobile Web Mail page that I have book marked in my iPhone Browser. They also allow for any number of "identities" for the reply to email. Hopefully a better Mail Client will be forth coming.
  3. ZBoater macrumors G3


    Jul 2, 2007
    Sunny Florida
    No, there is no way to change the Reply To address if you want to keep your Push Yahoo email account.

    The Yahoo Push Email account can ONLY be configured using the Yahoo email shortcut under Settings / Mail / New Account on the iPhone. Attempting to configure the Yahoo account (and expect to get push functionality) with any other shortcut will result in failure. Yahoo does NOT support IMAP for any clients OTHER than the iPhone. The Yahoo shortcut adds a special authentication to your settings that allows it to use from an iPhone. Any attempt to use that server from anything other than an iPhone will be rejected because the request will lack this authentication.

    Therefore, you are stuck with the that the shortcut adds to your ID. Its as simple as that.

    If you want to give up push, you can use the OTHER shortcut and change the address in the Account Information box.
  4. dukeblue91 macrumors 65816


    Oct 7, 2004
    Raleigh, NC
  5. ZBoater macrumors G3


    Jul 2, 2007
    Sunny Florida
    The OP title said Yahoo or GMail, but the post itself referred to Yahoo Push Email. On Yahoo Push Email, the answer is NO.

    On GMail, the answer is yes. By using the Other shortcut, you can specify a custom email ID and use the GMail servers. The caveat is that you MUST add this custom account address into the Settings of GMail using the GMail web interface. GMail must verify that you own that address before it will let you use its SMTP servers with an address other than Once you verify it (by entering a code sent to that address), then your messages will come from instead of
  6. mikeymoves macrumors member

    Sep 23, 2003
    My workaround is to have my POP account "Pull" the email as soon as the Yahoo email is "Pushed" to my phone. For instance...I get a little alert from my YAHOO account when an Email is pushed to my phone. I then go into my POP account and "Pull" that email and reply from there. Not the most elegant, but a simple workaround.
  7. mediarite macrumors newbie

    Jul 18, 2007
    Sorry if I'm being thick-headed, but what do you mean by "OTHER shortcut", and which "Account Information Box" are you referring to?

    I have a Gmail account. I redirect work mail to that account. I've told Gmail to use my work address as the reply-to address. That works OK if I send it from GMail. It doesn't work if I send it from the iPhone, using Gmail. It sounds like there's a workaround/fix, but I'm not figuring it out.

    Thanks for any help.
  8. ZBoater macrumors G3


    Jul 2, 2007
    Sunny Florida
    When you create your mail account on the iPhone, you need to go to Settings / Mail / Add Account / Other. You can define your GMail account there. You will see an Account Information box where you can put your name, your custom email address (not the GMail address) and an account description. Further down when you specify the incoming server, you put your custom (work, personal, etc.) incoming server, ID and password. For OUTGOING server you use, your GMail ID and GMail password. Hit SAVE. The account will be verified and all the settings will be set for you. You will now be able to use that account to receive your personal (non GMail) mail, and send using GMail's outgoing server.

    One more step you need to do is add your personal email address to the list of authorized accounts that can use GMail's outbound server. You can do this by logging onto GMail with a browser, hit Settings, and then choose Accounts. You will see where you need to add your personal email ID. GMail will want to verify it by sending you an email to that account with a verification code. Receive the email, enter the code into the box when prompted, and you are done with this piece. Now GMail will "recognize" you when you try to use its outgoing mail server while trying to use a non-GMail reply-to address, and it will go through.

    Here are the complete instructions I posted over at the Apple forums to help somebody else out. They were trying to use a COX mail account for incoming but wanted the option of using GMail as outgoing.


    First, create a free GMail account. Once you create it, log into it via the web, and enable POP access under Settings.

    Also under Settings, go to the Accounts tab and add your COX email address as an authorized account. GMail will validate that account by sending you an email with a verification code. Retrieve the email and code, and enter it when prompted by GMail, and that will allow you to use GMail's outgoing server with your COX ID as an reply-to address.

    Next, go to your iPhone. I suggest you delete and recreate the account from scratch.

    1. I went into Settings / Mail / Add Account and chose OTHER.

    2. I chose POP, then put my name under NAME, my custom ID

    (myid@myserver.comm in your case your COX ID) under ADDRESS, and "COX Email" under description. (The important thing here is to use your custom address, not your GMail address).

    3. Under incoming server, I put (your COX pop server), and my login ID and password (again, your COX ID and password).

    4. Under outgoing server, I put,, and my Gmail password. This is the only spot you need your GMail account and password.

    5. Hit save.

    Done. SSL and authentication are automatically set. I just tested it and sent myself an email, and it went out and came back as


    To go one step further, I would recommend having all your personal mail forwarded to your GMail account, and using the GMail information as incoming mail server. That way you take advantage of GMail's excellent spam filters.
  9. mediarite macrumors newbie

    Jul 18, 2007
    YES! That's what I was missing. The "Other" was the iPhone "Other" account instead of using the "GMail" setup.

    Works perfect.

  10. blackprius06 thread starter macrumors newbie


    Jul 13, 2007
    Gmail Option: A good fit

    The send through gmail option seems to be the best bet. I now have it set up as an "other" account checking my work e-mail via pop - but the outgoing set to send via gmail. Works on wifi and edge. Only thing - mail is delivered as "on behalf of" - not really a big deal - if one replies it goes to my work account.

  11. bhilton macrumors newbie

    Oct 6, 2007
    This is so easy!

    First you need to set up your free Yahoo account. This is best to use because of the "push" you are probably used to with a blackberry etc. Then set this up on your Iphone. On the phone....go to Settings, then to Mail, then to Add Account. Select Yahoo and fill in the information. It will as you for name: type in your name, then type in your yahoo email address, username and password. Select save. Once your Iphone has validated your Yahoo account your set. If you already have Yahoo set up on your phone....stay with me.

    Now go set up Outlook express so that it redirects your mail to your Yahoo account. Go to tools, then to Rules and Alerts. You need to create a new rule. Select: when your name is in the to: or cc: (or whatever other criteria you want), then click next, and Select: redirect it to (your yahoo acount). I recommend you use redirect because this sends the email to you as it came to your work account. If you select to have it forward to will get it in your yahoo account as if it is an email from you being forwarded. Because it redirecting the original email you also want to select leave a copy of the email in your inbox. Click next and be done. Now all of your work email will redirect to your Yahoo account which will push to your Iphone.

    Hopefully you do not use your yahoo account for anything else because you can then set your yahoo account your Iphone to reply to emails with your work address so that the person then gets the reply as if it came from your work account and they can then reply which will deliver to email.......and the circle continues. They way that you change address from which your Iphone uses to reply is easy......just go back into settings and mail and yahoo and change the email address to your work email address. This took me all day to figure out. Apparently that email address can be something other than

    No need to do magic tricks to ping gmail using their outgoing server.

    Now I will say this............GMAIL is great for filtering spam. But if "push" is more important......and to me it is.......then go this route.

    Oh by the "on behalf of"

    I also need to let you know that because you are changing the email in your Yahoo acount ON THE PHONE.....every email you send from Yahoo on your IPhone will say that it is come from your work account.
  12. marcfogel macrumors regular


    Oct 7, 2007
    This did not work for me on my free Yahoo account. The "sent from" address was yahoo
  13. bhilton macrumors newbie

    Oct 6, 2007
    Email on the IPhone

    I have a free yahoo account as well mine is working fine. I am going to write up the step by step process that I used with all of the settings I have on my phone and hopefully it will help. I would be happy to call you and walk you through it if you do not want to wait for me to post.
  14. theb macrumors newbie

    Oct 13, 2007

    Any idea when you will have the step-by-step process with settings added here. I am very anxious to get my iphone to do the reply-to-address as well. Currently I intend to forward my gmail emails to the my free Yahoo! account. The difference for me is I want to have a reply address of

    Looking forward to your comments.

  15. bigdaddymac macrumors regular

    Sep 20, 2007
    New York

    If you use these gmail/yahoo workarounds to receive "Push" email, can you still use IMAP folders? That is, when I receive an email and want to file it into a specific Folder when done with it, will my IMAP folders still be there, and if so, when I file an email forwarded through gmail or yahoo, will that message also be filed in the same folder on my desktop, so that all my mail is in sync?
  16. lordhamster macrumors 6502a

    Jan 23, 2008
    Sorry to revive a dead thread, but long searches on Google have yielded this as the only place I could find any discussion of this topic.

    My dilema was I have a Yahoo Account which I use for email and push, but I like to have my emails look like they are coming from my domain.
    On the Yahoo web interface this is no problem, but on the iPhone, not so easy. Well after reading this thread I tried what was suggested and it worked!

    First I used the Mail setup to add and account, then I used the Yahoo Button. I set up my yahoo account completely normally, I put in my address and password.

    No problems.

    Then after I confirmed the yahoo account was working, I went back into setup and changed the address field that had my yahoo account to be, I didn't do anything to any other fields. Now my emails I send from the iphone all go through Yahoo, work via push, but the recipient sees them as coming from Perfect!!

  17. tcpetersesq macrumors newbie

    Feb 4, 2008
    Still having trouble

    I am new here - so my apologies if this has already been covered. Like the last contributer, so also I have been unable to find any other forum where this topic has been addressed.

    I just acquired an iPhone. I've had a yahoo account for years, but I rarely used it. I successfully added my yahoo account to the iPhone. My thought was, since yahoo supported push, is that I would have all of my work email pushed through. It is far faster than waiting for the fetch with gmail.

    Problem - I can't seem to change the reply to address. I know where to change it - and I have changed it - but when I send an email from the yahoo account, the recipient still sees my yahoo account information, and not my work email address. I have followed the instructions in this post to a tee - but still no luck. :(

    Any words of wisdom? :confused:
  18. rje macrumors regular

    Feb 12, 2008
    This is the silver bullet. It works. You don't go back to Yahoo setup. You go to Settings/Mail/Accounts. There you can replace the Yahoo address with any one you want.
  19. tcpetersesq macrumors newbie

    Feb 4, 2008
  20. jhershauer macrumors member

    Feb 3, 2003
    Gilbert, AZ
    Works with 1.1.3?

    Did this work for you with iPhone software 1.1.3? I tried this, but get an error message when it goes to send the outbound mail: "Cannot Send Mail: The connection to the outgoing server "(null)" failed."

    If I change the email address back to my address in Settings/Mail/Accounts, it will go ahead and send the email. Now, if I'm willing to take a while to get my mail sent out, this does actually result in the email being sent from my work email address, as the email sitting in the outbox contains my work email as the Reply To address. It's just that I have to change the address back to yahoo in account settings in order to get the items in the Outbox to send.


  21. tcpetersesq macrumors newbie

    Feb 4, 2008
    I couldn't get it to work at all. No idea why. I ultimately managed to get my IT person at work to turn on the IMAP function on our exchange server, so I went that route.
  22. rje macrumors regular

    Feb 12, 2008
    It works for me with 1.1.3. Let the phone verify the Yahoo account. Once that's complete you should be able to enter any address. Enter it and just leave it. Don't press anything, just go back to the main screen.
  23. znino macrumors newbie

    Feb 25, 2008
    I concur with Jhershaur above. I can indeed go and change the replay to address after its been verified however, I can no longer SEND mail through the GMAIL account. I too get the error message saying it cannot send. I think that is probably normal since you are essentially trying to send a message through a yahoo server with credentials that are now no longer yahoo.

    Some people say this method has worked for them but I really can't send a message from that account on the phone once I replace the yahoo address. If I replace it back to my yahoo login, then the message leaves the outbox and gets sent. TOTALLY CONFUSED!!!
  24. nowayjoze macrumors newbie

    Jul 1, 2008
    This didn't work for me. How do I know what my 'incoming server and ID is for my work email? All I know is that I use Lotus notes. Do I have to get with my IT guy to get this information?

    Looks like I'm stuck using the 'From: isntead of my work email. :(
  25. nowayjoze macrumors newbie

    Jul 1, 2008
    Sorry for the bump but I'm getting really frustrated that I cannot change the 'reply to' or from address. Talked to my IT personnel and he mentioned that this will only work for blackberries...not iPhones. The servername was - it wasn't pop or stmp.

    Any clue to get this to work? I'm on 1.1.4 btw. It does work if I'm using the gmail web interface - just not on the iPhone.

    Edit: I think I got it to work now. On 'incoming' - simply use gmail...not your work email's address or server name. It was also set up as and on outgoing it was set up as Only time you needed to add any information on your work email was on the imap account information.

Share This Page