Can I disable internal keyboard/trackpad on MBP?

markw10

macrumors 6502
Original poster
Sep 4, 2006
371
0
Unfortunately my MBP has a serious issue with it's keyboard. Some keys such as the 0 and I no longer work. I was able to use a external USB keyboard to get around this problem. I don't think the Trackpad is having problems but since I have a mouse I use that. The problem is sometimes some keys are sticking so I can be in the middle of a Word document and my a key will start repeating that I'm not typing so the external Keyboard doesn't help in that case.
Since my MBP is over a year old it's not under warranty. I went to the Apple Store today and they can replace the keyboard for $150 plus labor in addition to it. With the new MBP's just around the corner I want to wait and upgrade to that so honestly, I just want life support now for my MBP until then. Is there any way I can disable the built in keyboard and just use the external USB keyboard for now? Is there some type of setting in the preferences or even a program I can use? I would imagine I can open it up and maybe pull a plug but I want to avoid this and don't what else may stop working.
 

forafireescape

macrumors 6502a
Jan 16, 2008
659
0
NJ
You can disable the trackpad when you have a mouse under system prefs, but I'm not sure about the keyboard.
 

XnavxeMiyyep

macrumors 65816
Mar 27, 2003
1,131
3
Washington
To disable the Macbook keyboard, type (or copy and paste) the following into terminal:

Code:
sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
To re-enable it, type (or copy and paste) the following into terminal (if copying and pasting, don't forget to copy a linebreak to make the command work):

Code:
sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
External keyboards will still work.

Also, I know this is a necrobump, but I haven't seen this solution anywhere online, and this thread had a lot of views.
 
  • Like
Reactions: Elenarella

mediamanjack

macrumors newbie
Jun 22, 2010
1
0
when ever I try the code to unload the keyboard I receive an error saying that it couldn't remove all instances of the process.

(kernel) Can't unload kext com.apple.driver.AppleUSBTCKeyboard; classes have instances:
(kernel) Kext com.apple.driver.AppleUSBTCKeyboard class AppleUSBTCKeyboard has 6 instances.
Failed to unload com.apple.driver.AppleUSBTCKeyboard - (libkern/kext) kext is in use or retained (cannot unload).
Is there a way to solve this?

also, the number of instances changes every time, but the disable works. Like I have no keyboard input. This code is going to be used for systems that I build for my company. used during a completely automated restoration process in case of system failure. I don't want the user to have any keyboard controls.
 

scapegoat78

macrumors newbie
Jul 2, 2010
8
0
huh

I got the command to work in terminal, but now I can't undo it (can't get my MBP keyboard to work now)--how do I insert a line break to make the second command work?
 

scapegoat78

macrumors newbie
Jul 2, 2010
8
0
This is the message I get when I insert the second code:

sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ ; exit;
kextunload: unload kext /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ failed
logout

[Process completed]
 

scapegoat78

macrumors newbie
Jul 2, 2010
8
0
actually

it says it's "already loaded" when i enter the undo--please help, I can't re-enable my keyboard!
 

XnavxeMiyyep

macrumors 65816
Mar 27, 2003
1,131
3
Washington
when ever I try the code to unload the keyboard I receive an error saying that it couldn't remove all instances of the process.



Is there a way to solve this?

also, the number of instances changes every time, but the disable works. Like I have no keyboard input. This code is going to be used for systems that I build for my company. used during a completely automated restoration process in case of system failure. I don't want the user to have any keyboard controls.
I honestly don't really know why the error appears. I suppose you could delete the keyboard kexts, but I'd rather not test that on my own machine. :p

Also, I'm not really familiar with corporate setups for Macs, but if you're seriously concerned about security, you'd probably want to disable USB and set some permissions and such.

I got the command to work in terminal, but now I can't undo it (can't get my MBP keyboard to work now)--how do I insert a line break to make the second command work?
You can copy and paste a line break by highlighting the space between two lines in a text editor or something, and right click and copy and paste.
This is the message I get when I insert the second code:

sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ ; exit;
kextunload: unload kext /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ failed
logout

[Process completed]
it says it's "already loaded" when i enter the undo--please help, I can't re-enable my keyboard!
Hmm... What version of OS X are you using? I'm on 10.6.3 and loading the second code (my keyboard is enabled) doesn't give me any error messages.
 

scapegoat78

macrumors newbie
Jul 2, 2010
8
0
I'm on 10.5.8--I can get the keyboard to work again by restarting the MBP--It's not the best solution but it's something. Thanks for the info.
 

Stingray454

macrumors 6502a
Sep 22, 2009
588
104
I'm also looking for a way to do exactly this. I tried the kextunload thing, and it does indeed disable the keyboard, but as scapegoat78 said, I can't re-enable it without a restart. Anyone know a way to do this with Snow Leopard (I'm on 10.6.4)?
 

Nappa

macrumors newbie
Jul 10, 2007
11
0
To disable the Macbook keyboard, type (or copy and paste) the following into terminal:

Code:
sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
To re-enable it, type (or copy and paste) the following into terminal (if copying and pasting, don't forget to copy a linebreak to make the command work):

Code:
sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
External keyboards will still work.

Also, I know this is a necrobump, but I haven't seen this solution anywhere online, and this thread had a lot of views.
Thanks. I had the same problem and this worked.
I got the same error messages as the posters above, but it still seems to disable the keyboard just fine.

One problem I have now is that although everything else works on my external (some bulky and crappy HP keyboard, this is just a temporary solution, getting a new MBP as soon as I have money) there is no volume buttons. "Scroll Lock" and "Pause" work as dimming and brighting up the screen but I tried every button and nothing controls the volume. Is there a way to bind these to the F buttons for example?

I used to use the ones on the internal, as they were one of the few buttons that still worked.

Strangely the F8-F12 seem to use Exposé and Dashboard, but F1-F7 don't do anything/work as F-buttons. This makes me believe it could be done.

e. never mind, I realized I could use spark to map it to any button combination
 

Cucuye

macrumors newbie
Dec 28, 2010
4
0
To disable the Macbook keyboard, type (or copy and paste) the following into terminal:

Code:
sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
To re-enable it, type (or copy and paste) the following into terminal (if copying and pasting, don't forget to copy a linebreak to make the command work):

Code:
sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
External keyboards will still work.

Also, I know this is a necrobump, but I haven't seen this solution anywhere online, and this thread had a lot of views.

Hello

I put the code in I think its working but it asks me to put in a password, and Iwhen I try to type the password nothing comes up, do you know why?

Cheers
 

XnavxeMiyyep

macrumors 65816
Mar 27, 2003
1,131
3
Washington
Hello

I put the code in I think its working but it asks me to put in a password, and Iwhen I try to type the password nothing comes up, do you know why?

Cheers
Yes, in the Terminal, when you type your password, nothing comes up. You simply type it, press return, and it will alert you whether you typed it wrong.
 

Cucuye

macrumors newbie
Dec 28, 2010
4
0
Yes, in the Terminal, when you type your password, nothing comes up. You simply type it, press return, and it will alert you whether you typed it wrong.
cool thank you, I managed to finally sort it, it wasn't working before as my system wouldn't let me type properly from interference from the faulty internal keyboard.
 

Cucuye

macrumors newbie
Dec 28, 2010
4
0
Yes, in the Terminal, when you type your password, nothing comes up. You simply type it, press return, and it will alert you whether you typed it wrong.
Hey im struggling with my keyboard and inputing my password, I don't suppose you know of a way to stop the password being needed?

or if there is another way of turning off the internal keyboard, preferably a way which isnt reset every time you restart the computer

cheers
 

theladyashley

macrumors newbie
Oct 7, 2008
10
1
Hey im struggling with my keyboard and inputing my password, I don't suppose you know of a way to stop the password being needed?

or if there is another way of turning off the internal keyboard, preferably a way which isnt reset every time you restart the computer

cheers
I'd also be interested in this information. I ever-so-gracefully knocked a cup of coffee on my macbook last week. It seemed to be working quite well up until today... Now when I try to log in to my user account (pw protected), I can't because at least one of the internal keyboard components is repeating and providing a lovely drum and bass soundtrack.

I need to disable the internal keyboard and just use my external so that I can wipe the macbook and hopefully sell for parts, but I can't get past the login screen. Any suggestions? :)
 

XnavxeMiyyep

macrumors 65816
Mar 27, 2003
1,131
3
Washington
Hey im struggling with my keyboard and inputing my password, I don't suppose you know of a way to stop the password being needed?

or if there is another way of turning off the internal keyboard, preferably a way which isnt reset every time you restart the computer

cheers
I'd also be interested in this information. I ever-so-gracefully knocked a cup of coffee on my macbook last week. It seemed to be working quite well up until today... Now when I try to log in to my user account (pw protected), I can't because at least one of the internal keyboard components is repeating and providing a lovely drum and bass soundtrack.

I need to disable the internal keyboard and just use my external so that I can wipe the macbook and hopefully sell for parts, but I can't get past the login screen. Any suggestions? :)
I suppose you could try deleting /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ and see what happens. Make a copy of the file somewhere else first though. If it screws things up, just move the copy back to the original location and repair permissions. I claim no responsibility for what happens if you attempt this.;)

If you can't access the Macbooks to log in (and thus delete the files), maybe try booting them in Target Firewire mode and deleting them from another Mac, although I realize that still might not work because of the messed up keyboard.

In this case you could attempt to take out the hard drive, put it in some sort of external SATA enclosure, delete the file with another Mac, put it back in your Macbook, and see what happens.

Again, standard disclaimer: I have attempted none of this. These are just solutions I thought of on the spot.
 

Cucuye

macrumors newbie
Dec 28, 2010
4
0
I deleted keyboard kext and i want it backed0000

I suppose you could try deleting /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/ and see what happens. Make a copy of the file somewhere else first though. If it screws things up, just move the copy back to the original location and repair permissions. I claim no responsibility for what happens if you attempt this.;)

If you can't access the Macbooks to log in (and thus delete the files), maybe try booting them in Target Firewire mode and deleting them from another Mac, although I realize that still might not work because of the messed up keyboard.

In this case you could attempt to take out the hard drive, put it in some sort of external SATA enclosure, delete the file with another Mac, put it back in your Macbook, and see what happens.

Again, standard disclaimer: I have attempted none of this. These are just solutions I thought of on the spot.


So I have ended up deleting the /AppleUSBTopCase.kext file, where can i download it again?
 

jlabes

macrumors newbie
May 10, 2011
1
0
KeyboardCleanTool

Andreas Hegenberg, of BetterTouchTool fame, has released an app which will disable the built-in keyboard so you can clean it, I expect it would do the job. It's called KeyboardCleanTool, and can be downloaded from http://blog.boastr.net/

You can set it to start disabling the keyboard as soon as it opens, so if you did that and added it to your login items, you would be set.
 

eckndu

macrumors regular
Jun 20, 2008
101
1
wow, finally found my cat proof tool
thanks jlabes and macrumor forum, i can always find what im looking for here.
 

VeeLow

macrumors newbie
Dec 6, 2011
1
0
bump

--this is seemingly the ONLY thread on the web that claims there's a way to shut off the MBPro internal keybd, so I'm jumping in here (small coffee spill; half-dozen dead keys).

I can't make the terminal script provided above work. have cut & pasted it and typed it in. no dice.

people above talk about line breaks, but there are no obvious line breaks in that line of text (the sudo command). so, anybody: help?

(I do get error messages when entering the code, similar to what people get upthread--but I also don't get my keyboard shutting off.)
 

phyrexia

macrumors 6502a
Sep 3, 2010
611
0
--this is seemingly the ONLY thread on the web that claims there's a way to shut off the MBPro internal keybd, so I'm jumping in here (small coffee spill; half-dozen dead keys).

I can't make the terminal script provided above work. have cut & pasted it and typed it in. no dice.

people above talk about line breaks, but there are no obvious line breaks in that line of text (the sudo command). so, anybody: help?

(I do get error messages when entering the code, similar to what people get upthread--but I also don't get my keyboard shutting off.)
The post refers to the line breaks at the end of the command. if you copy them along with the command, then pasting into terminal will automatically execute the command. if you do not copy them, the effect will be the same as typing the command in to terminal, but not hitting enter.
 

sy87

macrumors newbie
Jan 7, 2012
1
0
keyboard diable shortcut

playing around with the mac and found if u press the alt key 5x, it enables sticky keys. at first i thought it disabled the keyboard lol

oh yh also figured out a way to show your hard drive and root library n all that jazz in finder. whislt in finder click prefs then sidebar tab and select what u want shown...
 
Last edited:

Similar threads

  • MrGimper
0
Replies
0
Views
219
  • meteoreos
8
Replies
8
Views
1K
Replies
3
Views
694
  • streak8047
0
Replies
0
Views
558
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.