Can I disable iTunes from starting when I plug the phone in?

Discussion in 'iPhone' started by goodcow, May 11, 2009.

  1. goodcow macrumors 6502a

    Joined:
    Aug 4, 2007
    #1
    When I'm at work I want to just plug my phone in to charge, but each time either iTunes opens, or if it's already open, it steals focus, which is a really annoying "Windows" kind of thing to do.

    Automatic sync is disabled already. How do I just make iTunes ignore the fact that a device is plugged in?

    Thanks.
     
  2. Michael CM1 macrumors 603

    Joined:
    Feb 4, 2008
    #2
    I know there's a way because I changed it to that. But I can't find the setting. Someone else will have to point it out, but I know it's possible.
     
  3. pauld macrumors regular

    Joined:
    Feb 8, 2003
    Location:
    Tokyo (London for the holidays!)
    #4
    Taking this up one level, is it in any way possible to stop a 'sleeping' (i)mac from waking when an iPhone is docked? That one really grates on me.
     
  4. goodcow thread starter macrumors 6502a

    Joined:
    Aug 4, 2007
    #5
  5. Theaser macrumors 6502

    Theaser

    Joined:
    Dec 30, 2008
    #6
    How about don't open it at all before you plug it in, it has worked for me.
     
  6. Melrose Suspended

    Melrose

    Joined:
    Dec 12, 2007
    #7
    Hm. Well, I will admit I've never had to do that, but that's weird. A different version of iTunes perhaps? I dunno.. sry it didn't work.
     
  7. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #8
    I think this is the most you can do which, unfortunately, means you're probably out of luck.
     
  8. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #9
    Did you try unchecking the box that says "Automatically sync this iPod when connected"?
     
  9. goodcow thread starter macrumors 6502a

    Joined:
    Aug 4, 2007
    #10
    Yes, that's unchecked. Disable automatic sync is also checked under preferences -> devices.
     
  10. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #11
    Sorry, missed that on your original post. Is it iTunes or iPhoto that's popping up? I just tried toggling those settings on iTunes, and it works as expected. :confused:
     
  11. goodcow thread starter macrumors 6502a

    Joined:
    Aug 4, 2007
    #12
    iTunes.
     

Share This Page