Can I get opinions on a difficult MBP

Discussion in 'MacBook Pro' started by lisharts, Nov 16, 2010.

  1. lisharts macrumors member

    Joined:
    Aug 3, 2010
    #1
    Ok, I ordered my first MBP a few months back (15", i7). It arrived and within a few days I discovered one of the USB ports wasn't working. I called apple and they said because it was new they'd exchange it for a new one if I returned it. It was picked up and the new one was with me within a week. I was billed on September 28 for this replacement.

    New one appeared to work fine for a few weeks. Then I found some odd issues with the desktop background disappearing and going blue. If I tried to change the background it would change and work again. This tended to happen on exiting programs. On one occasion I remember it was upon exiting World of Warcraft.

    Then over the next few weeks things got worse. One day when trying to check on a password using keychain access I found when the admin box popped open requesting my username and password the box and it's buttons were all blank. When trying to type into the box I got the spinning wheel and couldn't enter any info. I googled the error and found a few people had it but there appeared to be no real solution. Someone suggested I reinstall. So I did.

    Once Snow Leopard reinstalled I ran a software update and it couldn't update automatically. It just kept throwing up errors. So instead I went on to the apple site and downloaded the listed updates one at a time and it let me install them that way (things like ilife support, the os x combo etc...).

    Then I tried installing Adobe CS3 and things got worse. The Adobe installer says it can't update the programs.

    Since I've tried reinstalling several times with no luck. The best balance I can find is downloading all updates as the software update never works, then telling adobe to never update.

    All software is legit, and beyond the programs and games I've mentioned I only install firefox.

    My question is - should I be concerned? I can't nip it into an apple store easily as my nearest is and hour and a half away. It's a brand new machine and it's been a total pain thus far. Am I doing something horribly wrong or could I possibly have a machine with errors?

    Any advice would be welcomed as I really don't know what to do. :(
     
  2. adpeace macrumors newbie

    Joined:
    Feb 28, 2008
    #2
    It would probably be worth doing a few diagnostics by the sounds of things just to be sure.

    I'd suggest running a memory test program such as memtest86+ - if you download the latest Ubuntu CD and burn it then you can run memtest from there. (The program itself is much smaller and you may be able to find an image with just that on, but the Ubuntu CD was the easiest way that came to mind.)

    You could also try running a hard disk diagnostic program. I'm not sure what's available on OS X but I believe there are graphical utilities hat can help - you need something that can initiate and report on a SMART test. Also, just using Disk Utility to verify and perhaps repair permissions may help.

    Hope that's helpful...
     
  3. zachsternelson macrumors newbie

    Joined:
    Nov 13, 2010
    #3
    Call AppleCare...?
    Go to a certified repair center?
     
  4. lisharts thread starter macrumors member

    Joined:
    Aug 3, 2010
    #4
    adpeace - Thanks for the helpful response. There are a few things there I'm not sure how to do (sorry, I'm not very technical!). I did try and repair disk permissions and it throws up a lot of errors that it says it fixes but still appear after the fix.

    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/dt.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jce.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jconsole.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/management-agent.jar", should be -rw-r--r-- , they are lrwxr-xr-x .

    These go on and on and so I won't post them all. I did a quick google on these and it seems a few people have similar sort of errors though and are advised to ignore them. So I'm not sure if that's a problem or not.

    Is there a chance this could be hardware related then? I presumed I might have messed the install process up but it doesn't seem like there's much I could have done wrong.

    Well this was next on the list really. I was posting here more to see if anyone had suggestions before I resign myself to it being broken (as it's a work machine and if I can fix it myself that would be ideal).

    I don't have the 3 year applecare. I am planning to pick it up before my year is up, it's just Christmas is just a bit close to spend so much money at the moment. Is that going to limit my repair options? Does anyone know if at this stage if it's still possible to send the machine back, or has that ship sailed?
     
  5. orangepeel, Nov 16, 2010
    Last edited: Nov 16, 2010

    orangepeel macrumors member

    Joined:
    Nov 10, 2010
    #5
    1. No, you are still covered under applecare.
    2. No, ship has sailed. You have 14 days for a return/exchange.

    Edit: Have you tried running the apple hardware test?

     
  6. lisharts thread starter macrumors member

    Joined:
    Aug 3, 2010
    #6
    Ok I'm trying the hardware test now.

    The problem is if this doesn't show anything up I wouldn't know what to ask them when I called. I managed to get the OS updated and iLife (just not via the software update window), and I would imagine they won't care too much that I can't get my Adobe CS3 suite upgraded because isn't that Adobe's problem? Even if I take it in won't they just run these same tests and tell me everything is fine? I just have an underlying feeling something isn't right with it. As when it arrived I had no trouble installing these sort of updates, it all started to go downhill after it was set up and working for a few weeks.

    Is it normal after a reinstall that software updates won't work? This is the first time I've reinstalled Snow Leopard.
     
  7. lisharts thread starter macrumors member

    Joined:
    Aug 3, 2010
  8. adpeace macrumors newbie

    Joined:
    Feb 28, 2008
    #8
    If Software Update doesn't work then there must be either a software or hardware problem somewhere so I think it would be reasonable to take it to the Genius Bar and get some advice.

    What is the actual error you see when you run Software Update?

    No, it should work just fine.
     
  9. khollister macrumors 6502a

    khollister

    Joined:
    Feb 1, 2003
    Location:
    Orlando, FL
    #9
    I would suggest, reinstalling OS X one more time. Try Software Update and if it doesn't run - leave it. That way when you take it to the Genius Bar, the genius can quickly see the problem (and it will be with Apple software). Otherwise you might run into a "cannot duplicate" problem.
     

Share This Page