Can I have menu bar + dock permanently visible

TonBil

macrumors newbie
Original poster
Oct 11, 2015
6
0
Apple Menu bar and dock disappear when I open e.g. OpenOffice. However, I want both to be visible on screen permanently. I used to have it like that before I updated to El Capitan today. The menu bar e.g. has the clock, that I look at quite often. The dock lets me switch easily (no, I don't want split screen). [see screen dump for what I mean]
I suppose I'm not the only one having this issue. I have been searching all over this forum and googled, but I can't find a way to "repair" this. Would be so grateful for a workaround. Thank you!

Schermafbeelding 2015-10-11 om 12.40.26.png
 

yansun

macrumors 6502
Mar 26, 2010
274
75
You're probably in fullscreen mode. Move to the upper left corner and press the green button to leave fullscreen mode. Then press and hold "alt" on your keyboard and press the green button again (+ symbol should appear at the green button instead of two arrows) to maximize/resize the window.
 
  • Like
Reactions: WarcraftWidow

TonBil

macrumors newbie
Original poster
Oct 11, 2015
6
0
You're probably in fullscreen mode. Move to the upper left corner and press the green button to leave fullscreen mode. Then press and hold "alt" on your keyboard and press the green button again (+ symbol should appear at the green button instead of two arrows) to maximize/resize the window.
Thanks, that's right! The OpenOffice window takes up approx. half the screen then. Now I would want to have that OpenOffice window maximized, but still keep the menu bar + dock in view. [see screenshot] That's how I had it till I installed El Capitan. I know that I can resize the OpenOffice window every time, but when I switch to firefox and back, OpenOffice is going to fill the complete screen again. And I switch quite often, since I'm editing a book and need access to internet and other stuff a lot. Thanks again for your help!

Schermafbeelding 2015-10-11 om 13.51.28.png
 

yansun

macrumors 6502
Mar 26, 2010
274
75
How do you switch between Firefox and OpenOffice? And what version of El Capitan is installed (I have the latest beta)? I don't use OpenOffice, but with MS Word I can't recreate the issue you have. If I max out/resize the Word window how I want it to have and switch between the browser through cmd + tab or Expose/Mission Control and MS Office it does not enter fullscreen mode but stays the way I resized it. Maybe it is a specific issue of OpenOffice?
 
Last edited:

TonBil

macrumors newbie
Original poster
Oct 11, 2015
6
0
How do you switch between Firefox and OpenOffice? And what version of El Capitan is installed (I have the latest beta)? I don't use OpenOffice, but with MS Word I can't recreate the issue you have. If I max out/resize the Word window how I want it to have and switch between the browser through cmd + tab or Expose/Mission Control and MS Office it does not enter fullscreen mode but stays the way I resized it. Maybe it is a specific issue of OpenOffice?
1. I swith between Firefox and OpenOffice by clicking the icon in the dock. THAT is why I want that dock available every time. Now it does not even always show up when OpenOffice fills up the whole screen (of my Macbook Air).
2. El Capitan OSX 10.11
3. The problem is not in one session but when starting a new session. It is time consuming to get the window of OpenOffice right. I never had the issue with earlier OSX (10.6 was my last, but I could not use certain apps with that anymore) and I hope to get rid of these unwanted "improvements".
Thanks so much for thinking along and helping!
 

dsemf

macrumors 6502
Jul 26, 2014
375
83
1. I swith between Firefox and OpenOffice by clicking the icon in the dock. THAT is why I want that dock available every time. Now it does not even always show up when OpenOffice fills up the whole screen (of my Macbook Air).
Sounds like you have the dock set to auto hide in system preferences. If auto hide is off, then zooming LibreOffice (OpenOffice should be the same), does not cover the dock.

DS
 

TonBil

macrumors newbie
Original poster
Oct 11, 2015
6
0
Sounds like you have the dock set to auto hide in system preferences. If auto hide is off, then zooming LibreOffice (OpenOffice should be the same), does not cover the dock.

DS
Hi dsemf, this helped! Thank you. Well then, the issue is solved now, and I thank all of you for your help.
 

TonBil

macrumors newbie
Original poster
Oct 11, 2015
6
0
Command + Tab allows you to quickly switch between apps as well.
Hi Simon, that's a good one - had forgotten about that option, since I never needed it. It works fine to switch between the two apps I used most recently. Very useful. Thank you!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.