Can I run my app on iOS7 w/o the iOS7 SDK?

Discussion in 'iOS Programming' started by moonman239, Jul 4, 2013.

  1. moonman239 macrumors 68000

    Mar 27, 2009
    I currently have a build on my iPad. Will it stop running if I update it?

    BTW, does the NDA prohibit discussion of topics like this on non-Apple forums?
  2. ArtOfWarfare macrumors G3


    Nov 26, 2007
    Two thoughts:
    1 - This should be discussed on Apple's devforums.
    2 - Anything you find there is subject to change during the process of the beta.
  3. moonman239 thread starter macrumors 68000

    Mar 27, 2009
    Here's a link to a thread on the Apple developer forums on this topic.
  4. jackal123uk macrumors member

    Jan 13, 2007
    Basically, as long as your app doesn't rely on APIs that have extensively changed in iOS 7 you should be fine.

    Personally all my iOS 6 built apps work fine in 7 but when moving from 5 to 6 the changes to Mapkit broke some of the functionality in a few of them.
  5. lastcall macrumors member


    Jan 10, 2013
    I'm sure when XCode 5 is released, you will find out. Just set the target to iOS 6.1, or whatever iOS you're targetting,
    and run it on iPad 7.0 simulator.

    If you need to run it on a real device, it looks like iOS 7 is limited to iPad 2 or later, or iPad mini.

Share This Page