can i still use i movie 09?

Discussion in 'Mac Apps and Mac App Store' started by apple1234, Jan 6, 2009.

  1. apple1234 macrumors newbie

    Joined:
    Jun 27, 2008
    #1
    well on the requirements of ilife 09 page it says i need a imac G5 with 1.9Ghz but i have 1.8 can it still work or will it be to slow to use?
     
  2. Dmac77 macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
    #2
    You won't be able to install it. And even if you did somehow install it, it would be painfully slow.

    Don
     

Share This Page