Can I Stop Applications "Stealing Focus" In Leopard/Spaces?

Discussion in 'macOS' started by duncyboy, Jun 9, 2008.

  1. duncyboy macrumors 6502a

    Joined:
    Feb 5, 2008
    #1
    OK, I got the phrase "Stealing Focus" from Opera- it has an option where no webpage can put it's tab to the front of your view over what you were doing.

    I've had iMovie doing stuff all night and when it's done generating thumbnails or rendering/exporting a movie it always jumps to it's Space. Even when I switch immediately back to what I was doing in another Space it sometimes does it.

    AARGH- :mad: -it's just done it now!!!

    Can't I just rely on the iMovie icon doing it's Zebedee impression on the Dock and switch back when I'm done?

    Other Apps do it too but iMovie's the main culprit tonight :eek:
     
  2. reubs macrumors 68000

    Joined:
    Jun 22, 2006
    #2
    I've noticed this same thing with iTunes. I'll plug in my iPod to update, go back to FF to keep browsing, and I keep getting popped down to iTunes to see what's happening there. If it needed me I can just rely on the hopping icon...I don't need to have it jacked up every time.

    Good question, OP. I had no way of figuring out how to explain it, and I think "Stealing focus" is a great way.
     
  3. duncyboy thread starter macrumors 6502a

    Joined:
    Feb 5, 2008
    #3
    I've Googled like mad but can't find an answer. There's definitely no option in Spaces/Preferences to change this but I hoped there was maybe a change that could be made in Terminal?
     
  4. 66217 Guest

    Joined:
    Jan 30, 2006
    #4
    I was trying to do the exact same thing. It happens ALL the time with Final Cut Express. I would let a movie rendering (suppose it takes 30 minutes to do it), and while it is rendering it would randomly jump to that space.

    I suppose this is a bug. I hope Apple fixes it.
     
  5. mcvaughan macrumors 6502a

    Joined:
    Aug 9, 2007
    Location:
    Houston, TX
    #5
    This is an annoying thing indeed. I have iMovie importing movies in one space and I'm trying to work in another when it keeps moving back to the space where iMovie is working. Ugh!
     
  6. mckyvlle macrumors 6502a

    Joined:
    Nov 21, 2007
    Location:
    London, UK
    #6
    You could try disabling Spaces auto-swoosh with this command:
    Code:
    defaults write com.apple.Dock workspaces-auto-swoosh -bool NO
    Remember to restart the Dock by:
    Code:
    killall Dock
    Note that this disable all forms all automatic switching between spaces, including clicking on the Dock icon.


    For more details, see this hint.
     
  7. BlakTornado Guest

    BlakTornado

    Joined:
    Apr 24, 2007
    Location:
    Washington, OH
    #7
    Hopefully Apple will stop this over-time. I have a feeling it may just be that it's outdated software that doesn't get on well with spaces, and a future update should fix it.
     
  8. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #8
    DVD captions do it.

    If you have a DVD playing, the captions cause it to switch back to DVD space every new line.
     
  9. duncyboy thread starter macrumors 6502a

    Joined:
    Feb 5, 2008
    #9
    How annoying is that? :eek:

    I'd forgotten about this thread. One trick I've found is to minimise the offending application- I know you could do that and stay in the same space anyways. For example, I load iMovie into Space 2 and import a clip so it copies and then generates thumbnails. Then press CMD & M and when it's ready the dock icon just boings up and down rather than "stealing focus"*

    (*I'm getting quite proud of that term now :D)
     
  10. billyork23 macrumors newbie

    Joined:
    Oct 28, 2009
    #10
    defaults write ... did not work

    FYI for others on this thread, using the defaults write trick did not work.

    I have an app running on another space and whenever it pops a window, it steals focus from the app in the current space.
     

Share This Page