can I stop the dock from hopping to other monitors?

Discussion in 'UI Customization' started by thefriendshipmachine, Apr 16, 2017.

  1. thefriendshipmachine macrumors member

    Joined:
    Apr 14, 2017
    #1
    hi friends

    I got another monitor and now when I touch the mouse to the bottom of the screen the dock jumps to the new screen.

    I changed my settings to treat all monitors as the same space and this fixes it but now I cant treat each monitor as its own space which I liked.

    Does anyone think there is a way to have both?
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Move the dock to one side (?)
    I usually use the right side for the dock.
     
  3. thefriendshipmachine thread starter macrumors member

    Joined:
    Apr 14, 2017
    #3
    If I do this then the dock goes to my external monitors and I would rather have it on the bottom or the side of my imac screen
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    I agree.
    You can move your displays around in Displays pane/Arrangements tab, to get the position you prefer.
    Of course, that only works if you are not using mirroring.

    In my setup, my external display is on the left, and the internal is set as the main display, so the Dock has no other place to go.
    My external is actually a projector, so I have that display positioned almost corner-touching-corner, so I don't randomly "lose" the mouse on the external screen, as that screen is 50 feet from the internal screen.

    It sounds like you have more than one external monitor?
    How do you have those set up in your Arrangements tab?
     
  5. thefriendshipmachine thread starter macrumors member

    Joined:
    Apr 14, 2017
    #5
    I have 2 externals which are on each side of my imac in the middle
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Does your arrangement tab show the same layout as your physical positions?
    Does it make any difference for you if you move the positions on the arrangement tab, so the displays are corner-to-corner, rather than edge-to-edge?
    (Not sure if that makes sense when I read it. It's easier to try it out in Arrangements, where that is simple to create :D )
     
  7. thefriendshipmachine thread starter macrumors member

    Joined:
    Apr 14, 2017
    #7
    that would be a clever trick to let me put the dock on the side!
     
  8. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    All you need to do is move it in the settings.
    All depends on how you want the screens positioned in the Displays pane. The main screen (with the menubar at the top) would have to be positioned to one side for the dock to be on THAT side (rather than have your main screen in between the two externals)
    Does that make sense?
     
  9. AdamA9 macrumors 6502a

    Joined:
    Feb 2, 2010
    #9
    It's not that simple. I have the same problem on my MacBook Pro. I set my MacBook screen as the main screen is displays, but everytime I move my cursor near the bottom of my external monitor, the dock jumps over there, despite being my second screen and not the main one.

    Really annoying and I still cannot find a way to resolve this.
     
  10. MyopicPaideia macrumors 68000

    MyopicPaideia

    Joined:
    Mar 19, 2011
    Location:
    Trollhättan, Sweden
    #10
    Sorry to chime in and maybe ask a stupid question, but do you have the dock set to auto-hide? If so, does turning that off help at all?

    I always have the dock on auto-hide and noticed that the dock (and menu bar) will plant itself in whatever screen you make your primary, and that this is easily switched back and forth by simply moving the mouse to the bottom of whichever screen your mouse is active in. Once you make the dock pop up in this way, the menu bar seems to follow and that screen become the primary...

    Always was just a minor irritation for me, so never even tried to see if turning off auto-hide would have the secondary effect of "locking" it to the primary screen...
     
  11. AdamA9 macrumors 6502a

    Joined:
    Feb 2, 2010
    #11
    I don't use auto-hide, but what you explain is my issue. Accidentally moving the mouse to the bottom of my secondary screen brings with it the dock. I don't want this to happen and cannot see a way to turn it off.
     

Share This Page