Can I tether with ios4 on an iPhone 3GS

Discussion in 'Jailbreaks and iOS Hacks' started by cmm, Sep 19, 2010.

  1. cmm macrumors 6502a

    Joined:
    Apr 30, 2006
    Location:
    Manhattan & Zürich
    #1
    Hi all,

    I have an iPhone 3GS that I haven't updated because I really appreciate the tethering feature. However, I'd like to upgrade to ios4 -- is tethering possible with any of the ios4 versions on an iPhone 3GS?

    Thanks!
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Not on stock 4.0 with config files like before. Only if you jb.
     
  3. cmm thread starter macrumors 6502a

    Joined:
    Apr 30, 2006
    Location:
    Manhattan & Zürich
    #3
    Thanks. Can you point me to the relevant JB for this model (iPhone 3GS) so I can tether? I want to make sure I'm following the proper guides, so tethering *is* possible, otherwise, I don't want to upgrade. What is the highest version of iOS4 I can use to tether with a jailbroken/unlocked iPhone 3GS?

    Oh, I'm on AT&T and my current software is 3.1.2

    Thank you!
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    You will need shsh's saved for 4.0.1 so u can restore to that and jb. If not you can wait till the 4.1 jb is out and then update and jb.
     
  5. cmm thread starter macrumors 6502a

    Joined:
    Apr 30, 2006
    Location:
    Manhattan & Zürich
    #5
    What is shsh? Does jailbreakme.com work for me in this instance?
     
  6. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #6
    I have an iPhone 3GS with iOS 4 and with native tethering. It depends on what carrier you are using. iTunes asked me for a carrier update and it gave me the native tethering.
     
  7. JrFreak macrumors 6502a

    JrFreak

    Joined:
    Aug 3, 2009
    #7
    Download 4.0 fireware and restore to it. Then use jailbreakme.com. Easy as that...
     
  8. cmm thread starter macrumors 6502a

    Joined:
    Apr 30, 2006
    Location:
    Manhattan & Zürich
    #8
    Simply 4.0? No 4.0.1? I just want to be sure. I read that the jailbreak for 4.1 isn't out yet, so I won't go and download that...

    JrFreak: I have AT&T. Will using jailbreakme.com give me tethering support, as I already have in 3.1.2?

    Thank you very much everybody!
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Yeah, only if it was that easy:rolleyes:
     
  10. cmm thread starter macrumors 6502a

    Joined:
    Apr 30, 2006
    Location:
    Manhattan & Zürich
    #10
    Can you please tell me if post #8 is correct? I want to do the jailbreak and have tethering on AT&T in as little time as possible, without any major problems that cause my phone to be a brick for longer than it has to be. (I did the jb of 3.1.2 in about 1 hour, seems reasonable...)
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11

    Post #8 is false.
    You need shsh's to restore to 4.0 or 4.0.1 or to any firmware besides the latest 4.1 thats out right now.
    Apple does not allow restores or updates to anything but the latest built out. Thats why you need those shsh blobs in order to allow you. But if you dont know what they are you probably dont have them saved on cydias server.
    Download tinyumbrella and check to see what shsh's you have on file.
     
  12. cmm thread starter macrumors 6502a

    Joined:
    Apr 30, 2006
    Location:
    Manhattan & Zürich
    #12
    Thanks. I just ran it and got this:

    09/21/2010 12:32:56.616 The Firmware Umbrella - v4.1.4 by semaphore 09/21/2010 12:32:56.624 For help click here
    09/21/2010 12:32:56.629 Connect a device to continue...
    09/21/2010 12:32:57.775 Caching shsh files...
    09/21/2010 12:32:57.795 Found [0] shsh files to cache...
    09/21/2010 12:32:57.853 Cached [0] shsh files
    09/21/2010 12:33:02.524 You are using the current version of TinyUmbrella. 09/21/2010 12:33:03.234 Device Detected - Device: iPhone3GS 3.1.2 (7D11) Model: MC135LL/A Name: John Smith’s iPhone UUID: XXXXXXXX Baseband: 04.26.08 - 6.4_M3S2


    What do I need to do now to get 4.0.1 so I can run jailbreakme.com from my phone?

    Thank you!
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #13
    Make sure your iphone is plugged in first.
    Click advanced options
    Request version iphone 3GS 4.0.1
    Request From Cydia
    And let me know what it says.
    After that click display shsh's
     
  14. Rajani Isa macrumors 65816

    Rajani Isa

    Joined:
    Jun 8, 2010
    #14
    The issue is you would not have the SHSH blobs for 4.0/4.0.1.

    When you install a firmware, it calls home to Apple to get approval - the return is the SHSH "blobs" - but Apple is now signing/approving only 4.1.

    Once you've done this and Jailbroken, Cydia can save the blobs - but since you didn't update before they stopped signing 4.0 you are (temporarily) out of luck.

    However, 4.1 is close to having a working JB released, from what I understand.
     
  15. cmm thread starter macrumors 6502a

    Joined:
    Apr 30, 2006
    Location:
    Manhattan & Zürich
    #15
    Hey, what do I do after I follow that? Nothing in the box below changes when I go through that. Do I need to click the button "Save my SHSH" next?

    Thanks!
     

Share This Page