Can I unlock with Ultrasnow?

Discussion in 'Jailbreaks and iOS Hacks' started by Happytodd, Apr 11, 2011.

  1. Happytodd macrumors regular

    Joined:
    Oct 19, 2010
    #1
    Can I unlock my iPhone 4 with Ultrasnow, and if so, can I later decide to restore my phone and not have it jailbroken, will it still be unlocked or do I have to unlock it everytime I decide to jailbreak my iPhone?

    Version: 4.1 (8B117)
    Modem Firmware: 02.10.04

    Will my Phone Provider get told or lock me out in anyway if I tried doing this?, I'm with Optus in Australia?

    Thankyou very much!
     
  2. anthdci macrumors 6502

    Joined:
    Jun 8, 2009
    #2
    no, 02.10.04 cannot be unlocked using ultrasn0w yet. If/when it can be you will need to stay jailbroken and have ultrasn0w installed, restoring will relock the phone. Your provider wont know if you have unlocked
     
  3. Happytodd thread starter macrumors regular

    Joined:
    Oct 19, 2010
    #3
    Ok, thankyou very much for this! :D
     
  4. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #4
    If you're dependent on an unlock, you'll have to use pwnage or your blobs to keep the bb from upgrading when you install a new iOS or restore your phone. If you had a 3G/3GS, you wouldn't be able to use blobs.
    Because your bb is too high, you can't unlock now.
     
  5. Rizvi1 macrumors 6502a

    Joined:
    Mar 29, 2006
    Location:
    Laurel, MD (Baltimore, MD / Washington, DC area)
    #5
    Can I add on my own situation here regarding the new ultrasn0w? I've asked around in a few threads but haven't seen an answer that made me confident. Perhaps someone can help?

    I bought this iPhone 3gs last August and at the the time, the latest firmware was able to be jailbroken and unlocked so we could use on t-mobile. It's been on it's Version 4.0 (8A293) / Modem Firmware 05.13.04 since. Lately the phone's been freezing up a lot. I wasn't sure how to go about restoring or upgrading the FW w/out risking losing the unlock.

    Not sure if it helps but I took a screenshot of Cydia on the phone:
    http://twitpic.com/4gatf1

    Does this mean I have all these SHSHs saved? SHSH: iOS 4.0, 4.01, 4.1, 4.2.1+, 4.3 . Could it help me with anything.

    perhaps I could just restart it from scratch to whatever the latest version is that is unlockable if I have these SHSH saves? or is that not how they work?

    If the phone still acts up, and I want to take it to the Apple store because it has applecare. But i'm not sure what would happen if they swap it out with a replacement 3gs.
     
  6. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #6
    ^^^^

    Your baseband is what decides if you can unlock with Ultrasnow or not. With 5.13 baseband, you can. Thus, you should always keep that baseband if when updatig or restoring you firmware. To do that, use a custom firmware file, obviously one that keeps your current baseband. Having saved SHSH blobs allows you to restore with the custom firmware file you have blobs for. For example, if I wanted to restore to a 4.2.1 custom file, I will need to have previously saved 4.2.1 blobs.
     
  7. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
  8. Rizvi1 macrumors 6502a

    Joined:
    Mar 29, 2006
    Location:
    Laurel, MD (Baltimore, MD / Washington, DC area)
    #8
    Thanks a lot for the response. So if I want to go to 4.3.1, I have to find a custom firmware file with that and that let's me keep my baseband. Is there a link on where to find this file and the steps to follow to use it? I'll attempt to upgrade the FW tonight and then re-jailbreak/re-unlock to see if the phone stops acting up.

    And as far as my second question, if I go to the latest firmware and my phone's still acting up, I can't take it in to the Apple Store yet correct? Because they may swap to a different 3gs and if it's the latest FW/Baseband, it would not be unlockable?
     

Share This Page