Can I Update Safely To Latest OS?

Discussion in 'MacBook' started by ukeypride, Feb 22, 2017.

  1. ukeypride macrumors newbie

    Joined:
    Feb 22, 2017
    #1
    I have an old IMAC and am still running OS 10.8.5. Reluctant to update to latest OS because I'm afraid my Final Cut Express 4.0.1 won't work. Does anyone know if it will? I also have Photoshop 12.0.4 and Adobe Indesign CS5. Wondering the same about those two packages if you happen to know. Thanks in advance.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    CS5 will certainly have issues, especially if you have a lot of custom fonts. FC Express is almost a decade old and wasn't even their flagship Pro product at the time, so I wouldn't hold high hopes for it.
     

Share This Page