Can i use sdk 3.0 to develope for os2.2.1 ?

Discussion in 'iOS Programming' started by recobe, Jun 15, 2009.

  1. recobe macrumors newbie

    Joined:
    Jun 15, 2009
    #1
    i'm very newbie for this.
    Can i use sdk 3.0 to develope for os2.2.1 ?
    on the other hand
    use sdk 2.2.1 for os 3.0 can i ?

    thanks
     
  2. uberamd macrumors 68030

    uberamd

    Joined:
    May 26, 2009
    Location:
    Minnesota
    #2
    Apps are no longer accepted for anything under 3.0.
     
  3. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #3
    Please consult the "Read me before downloading" section of the iPhone SDK 3.0 view of the iPhone Dev Center.

    Really? Has Apple stated this?
     
  4. BlackWolf macrumors regular

    Joined:
    Apr 9, 2009
    #4
    yes
     
  5. DaveP macrumors 6502

    DaveP

    Joined:
    Mar 18, 2005
    #5
    I don't have the document available right now, but I thought I read in the release notes that the 3.0 SDK could now to used to submit 2.X apps (indicating it's still fine). Also, on iTunes connect there is a check-box for "Compiled with 3.0" again indicating it doesn't need to be.

    Black Wolf, can you point out some documentation or something to show that? This would be very major.

    (Edit) From the iPhone developer page: "iPhone SDK 3.0 GM Seed can now be used for submitting iPhone OS 2.2.1 and iPhone OS 3.0 applications to the App Store."
     
  6. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #6
    Thanks for that well-backed-up claim. :rolleyes:
     
  7. admanimal macrumors 68040

    Joined:
    Apr 22, 2005
    #7
    I have a feeling this is another case of the uninformed confusing "must be compatible with iPhone OS 3.0" with "must be compiled for iPhone OS 3.0"
     
  8. wlh99 macrumors 6502

    Joined:
    Feb 7, 2008
    #8
    Not that I have seen. What I saw was that apps had to be tested for 3.0. In fact, an app I summitted a week ago for 2.2 was approved this morning.

    The iPhone 2.2.1 sdk is still available on the front page of the dev center.

    I have several SDK's installed. The 2.21 sdk will build for 2.0, 2.1, 2.2,and 2.21.
    The 3.0b5 would only bulid for 3.0b5.
    The 3.0GM builds for 2.21 and 3.0GM.

    Since not everyone will want to upgrade to 3.0, it would not make sense to target that OS unless there was a specific feature you wanted to take advantage of.
     

Share This Page