Can iPhone 5 **not** do an actual hard reset?

Discussion in 'iPhone' started by thadoggfather, Nov 18, 2012.

  1. thadoggfather, Nov 18, 2012
    Last edited: Nov 18, 2012

    thadoggfather macrumors G3


    Oct 1, 2007
    When I do a hard reset (home button+lock button until seeing apple logo again) and make sure going to settings->general->about-diagnostics with "do not send" checked i see in the resetcounter log and see nothing but "boot failure count: 1"

    Also, I say "do not send" should be checked because otherwise you can't read the contents of the diagnostic log files, it's just blank (probably gets wiped from the device once it gets sent to Apple, I'd suspect)

    it has never said "reset count 1" on my device, on 6.0 or 6.0.1 set up as new or restored from backup

    On my ipad3, on 5.1.1 granted, when I do a hard reset it says "reset count: 1."
    on my 3gs on 5.1.1 it says "reset count 1" half the time and "boot failure count 1" the other half.

    Can someone check on their iPhone 5 and see if it does the same thing as mine, and that is, always shows "boot failure count 1" when doing a hard reset in the diagnostics log?

    I've also had three re-springs in the life of the phone (on 6.0) but apparently some other people have too but possibly for different reasons, mine seem random (and always in the photos app somehow but maybe because I take and look at pictures a lot).

    Am I just being really paranoid or is there something wrong with my phone?

    I don't want to keep having to swap out my phone, its getting nuts.

    edit: did a dfu restore to 6.0.1, tried hard resetting, still says "boot failure 1" consistenly in the diagnostic logs :/
  2. thadoggfather, Nov 18, 2012
    Last edited: Nov 18, 2012

    thadoggfather thread starter macrumors G3


    Oct 1, 2007
    447 views and no one has followed up?

    I'm just so baffled how my phone could do a reboot holding both those buttons but not actually work its magic in terms of doing the hard reset itself. Or how this could be a hardware issue?

    Unless I'm looking too much into these diagnostic logs?
  3. thadoggfather thread starter macrumors G3


    Oct 1, 2007
    ok so one more update.

    I tried doing a hard reset on my brother's iPad2 on 6.0.1 as well.

    Three times. All did "boot failure 1" in resetcounter logs. Now I am looking too much into these logs, but maybe this means that iOS 6 as of now can only do a soft reset but not a hard one? I dunno. Seems like they heavily overlooked something here.

    ...Glad to know it's not just my device but rather seems specific to the software. Very pleased as I didn't want to do the "swap game" anyways for a seemingly statically mythical, good one (the one I currently have I would consider to be that, minus the re-spring and this diagnostics log hunting both of which are apparently not uncommon).

    Now give me my iPhone 5 jailbreak so when weird hiccups happen, I can attribute it to custom code and not buggy STOCK software or worst case scenario, a hardware issue :D

    I thought it was awfully weird that if this were a hardware issue, I could still have successfully put the device in DFU mode and load 6.0.1 from iTunes without it showing an error (bricked device, internally messed up).

    Patiently waiting now. I think at this rate, we might not see JB til at least 6.1 release next year though.

    I hope somebody found this interesting haha
  4. Justinb51 macrumors 6502


    Apr 9, 2010
    Indianapolis, IN
    iPhone 5 on 6.0. I did a hard shut down and then when I checked I did not have that error message. I do not send to apple. Fyi
  5. thadoggfather thread starter macrumors G3


    Oct 1, 2007
    So I tried same thing on multiple devices with iOS 6: iphone 5, another 5, mini, iPad 4, iPad 2 they all report the same thing in the diag log.

    I also noticed when holding both you don't see a slide to power down anymore like you did when hard resetting any other previous iOS version

    Really surprised. And at the same time, not. :)
  6. tymaster50 macrumors 68030


    Oct 3, 2012
    New Jersey
    Is this affecting your phone? If not then stop worrying.
  7. stoneland macrumors member

    Nov 4, 2012
    Hey OP, you're right. I just checked mine because I reset it last night and it says "Reset count 0"...that's so weird. I've never actually checked it when I had the 4. It doesn't really bother me that it's not an actual reset, but that's still interesting...wonder what the power button + home button actually does then.
  8. diegoesk macrumors regular

    Dec 19, 2010
    probably just a software issue. Send to apple im sure they will fix.

Share This Page