Can Jailbreak, but can't boot tethered...

Discussion in 'Jailbreaks and iOS Hacks' started by GoKyu, Dec 31, 2010.

  1. GoKyu macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #1
    Hey all, I got the phone jailbroken with Redsn0w 0.9.6b4, and I have the correct firmware restore (8C148), and running OS X 10.6.5.

    I have the Cydia icon on the phone, but it's white - and having successfully done this before, I knew I'd have to reboot tethered in order for Cydia to work.

    But since then, I haven't been able to reboot into tethered mode - I can get the phone into DFU mode just fine, but what happens is, it will say "Waiting for reboot", then give me:

    "An unexpected error occurred. Please try again. Try rebooting your device and changing USB ports.

    Unexpected error!"

    I've tried 3 other USB ports, but I don't think that's it. Another interesting issue is that even with the phone turned *OFF*, now whenever I open iTunes, it will pop up this message:

    "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes."

    How can it detect a phone that's turned off? I think this might be the issue...

    I've been searching for something similar online, but haven't found much.

    Anyone know how to fix this and allow me to boot tethered? Any help is greatly appreciated!
     
  2. iloveiphone4 macrumors member

    Joined:
    Jul 7, 2010
    #2
    i dont think yuor phone is switched off, it is in DFU mode, in that mode, your phone screen is blank and itunes will say your phone is in recovery mode.

    Also, double check the apple firmware file, when I had the same problem, the culprit was the firmware file and I am guessing it is in your case too. download from a different source if possible.
     
  3. GoKyu thread starter macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #3
    Will try a new firmware version, but when I said the phone was off, I mean I physically turned it OFF after an unsuccessful boot, and when I launched iTunes, it gave me that message.

    Right now I have iTunes running and my iPhone is turned on and plugged in (still not booting tethered), and iTunes is showing my phone (Bryan's iPhone) AND some phantom "iPhone" entry that has no information in it.

    I don't understand why it would be so easy to do the first time, and then impossible to do the exact same thing (just changing from "Install Cydia" to "Just boot tethered for now") immediately after that.
     
  4. CZK macrumors 6502a

    Joined:
    Oct 25, 2010
    #4
    Its a Beta version, no one can help you since the program is not even ready to use.

    Wait the Vfinal imo.
     
  5. ignus graius macrumors regular

    Joined:
    Dec 4, 2005
    #5
    The current redsn0w beta installs the kernel for iOS 4.2b3 to boot your phone, then switches to 4.2.1. I imagine that if you're selecting 4.2.1 as your current firmware (to boot tethered) that it's failing because it's trying to hack the kernel for 4.2.1, and your phone has the kernel for 4.2b3.
     
  6. GoKyu thread starter macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #6
    That's a good theory, but I thought 4.2b3 was only for the beta *untethered* jailbreak, which I'm not trying to use.

    One other piece of info I forgot to add: I jailbroke last week successfully - booted tethered successfully, installed Cydia, and even purchased MyWi. After rebooting from THAT purchase, the phone got stuck in a loop (Apple logo), so I had to do a complete restore several days ago.

    Since then, it seems like I can do the actual jailbreak without any issues, but when I try to boot tethered, Redsn0w gives me that "unexpected error" message.

    Should I maybe try a newer version of Redsn0w (currently using the b4)?
     
  7. iloveiphone4 macrumors member

    Joined:
    Jul 7, 2010
    #7
    you should not be using the new beta versions, just find on any site where the original boot tethered version of redsnow is and use that.. you dont need the latest untethered version to do a tethered boot.

    are you a mac user ?

    you dont need the 4.2b3 and there are no bugs in the tethered boot version as i used it many times and it does it properly. just make sure you downloaded the right version of redsnow(not the latest betas) and the correct firmware file. i would suggest redmondpie for the source of redsnow and instructions and apple for the firmware file.
     
  8. GoKyu thread starter macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #8
    I didn't think I needed all that stuff....yep, I'm on OS X, I'll grab some fresh versions of the files from RedmondPie (Can't remember where I got these last ones - maybe that's the problem...)

    I restored the phone earlier, and will try again with the new copies. Will post back next year :)

    Happy new year!
     
  9. sippyyy macrumors newbie

    Joined:
    Jan 18, 2011
    #9
    Any update on this? I seem to be having the exact same problem!
     
  10. GoKyu thread starter macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #10
    Nope, never had any more luck with it - it would JB, but then wouldn't let me boot, so I restored. I'm about to try updating to 4.3 and JB'ing that one...will post back if it works.
     

Share This Page