Can no longer click on trackpad (Yosemite, mid-2009 MBP)

Discussion in 'MacBook' started by TJ82, Nov 30, 2014.

  1. TJ82 macrumors 6502a

    TJ82

    Joined:
    Mar 8, 2012
    #1
    Girlfriend started complaing last night that she couldn't click and drag to highlight text all of a sudden. I played around with it, trying different Apps and browsers and seems like she was correct. Restarted and reset the PRAM and still didn't help.

    Went to deselect the option 'Tap to click' in preferences, and was going to reselect it again when all hell breaks loose.

    Can no longer click at all, in any way. Can't even find a way to get back into system preferences to reselect 'Tap to click'.

    Anyone seen this problem before, is there any way out of clickless hell?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    You can activate the "tap to click" from the Terminal.

    Do this :

    - Cmd + space bar to get Spotlight.
    - type in : terminal
    - the Terminal.app should show up as best result, otherwise use the down arrow to highlight it, then hit Enter
    - in the Terminal window, type in :

    Code:
    defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -bool true
    - hit Enter
     
  3. TJ82 thread starter macrumors 6502a

    TJ82

    Joined:
    Mar 8, 2012
    #3
    Clever! Thanks!

    Doesn't work unfortunately :mad:

    It's an inbuilt trackpad, maybe it has a different name?
     
  4. Jillykid macrumors newbie

    Joined:
    Nov 30, 2014
    #4
    Same problem. Its got to be software related. External mouse or trackpad acts the same. Scrolling fine but clicking not functioning

    New macbookpro 2014!

    ----------

    It's not a settings issue mouse click is also non functional. Impossible to do anything
     
  5. sealdriver macrumors newbie

    Joined:
    Feb 19, 2012
    Location:
    North Yorkshire, United Kingdom
    #5
    Try enabling dragging in the trackpad options of 'Accessibility' in system prefs.
     
  6. TJ82 thread starter macrumors 6502a

    TJ82

    Joined:
    Mar 8, 2012
    #6
    How to enable it if you can't click it :cool:
     
  7. sealdriver macrumors newbie

    Joined:
    Feb 19, 2012
    Location:
    North Yorkshire, United Kingdom
    #7
    Have you tried command-alt-F5, tab to enable mouse keys, hit space bar. Then go to prefs and trying to set with mouse keys?

    Not sure if it will work but worth a try.
     

Share This Page