Can no longer connect via SSH on one Mac, but can on all others.

Discussion in 'macOS' started by marcamos, Jun 8, 2009.

  1. marcamos macrumors newbie

    Joined:
    Jun 8, 2009
    Location:
    Beverly, Massachusetts
    #1
    Long time Mac user; newb at this forum, though. Here's my predicament and Google hasn't turned up anything I understand:

    - I've got a MBP running latest Leopard
    - My wife has a MB running the same
    - I pay for a web-server with SSH access
    - I have a standard internet connection at home
    - I have a standard internet connection at my office

    I've been able to connect to the webserver, via SSH, for the longest time from my own MBP. All of a sudden, and I can't pin-point exactly when, my MBP gets the following message when I type "ssh root@mydomainname.com" in Terminal.app:

    ssh: connect to host mydomain.com port 22: Connection refused

    So, it's not my credentials, but access altogether, it seems.

    "Okay, so my webhost closed SSH access, I'll give them a call." Nope, they say it isn't closed and that they can connect just fine.

    I send an instant message to a friend, ask him to type in "ssh root@mydomainname.com" in his instance of Terminal.app, and he gets through just fine, and is asked for the password.

    "Okay, so it's my network here in the office." So, I take my MBP home and try it from there. Same issue. I walk five feet over to my wife's MB, and it works perfectly: I am asked to enter my password.

    So, I go through my system preferences, note the firewall preference, which is set to "Allow all incoming connections," and I am baffled. Any ideas why only my Mac won't connect via port 22, and what else I should inspect?

    Thanks, all.
     
  2. marcamos thread starter macrumors newbie

    Joined:
    Jun 8, 2009
    Location:
    Beverly, Massachusetts
    #2
    I figured out the problem. Using MAMP, I had set a domain mask to be the very same domain of my external web server. SO ... Terminal was attempting to SSH into my local computer (which I didn't know), and, because Remote Login is turned off, over in System Preferences, it was denying me.

    Remove the domain mask in MAMP, and viola, I can SSH into my web server again.
     

Share This Page