Can no longer launch videos from iPhoto

Discussion in 'Mac Apps and Mac App Store' started by Ack, May 5, 2010.

  1. Ack macrumors member

    Joined:
    Jan 15, 2009
    #1
    I was previously running Leopard with iPhoto '08. With this setup all .mov format movies that I took with my digital camera imported into iPhoto along with the pictures. They showed up in thumbnail view along with the pictures and I could launch the movies in Quicktime by double-clicking on the movie thumbnail in iPhoto.

    After upgrading to Snow Leopard (but still using iPhoto '08) the video thumbnails still show up, but double-clicking on them does nothing. Double-clicking on image thumbnails still opens the image as normal. I can still view the movies by right-clicking, selecting "show file," and then double-clicking on the movie thumbnail in Finder.

    I'd like the get the view movies from iPhoto functionality working again. Any ideas?
     
  2. Ack thread starter macrumors member

    Joined:
    Jan 15, 2009
    #2
    I found a partial solution here: http://support.apple.com/kb/TS3003

    Apparently iPhoto 08 is trying to launch QuickTime 7 instead of SL's QuickTime X to view the videos. The solution is to manually install QT7 from the SL DVD.

    This solution kind of stinks because I'd really like to have the features of QT X when I work with my videos through iPhoto. Apparently there's no solution for this other than to upgrade to iLife 09. It seems like it should be pretty simple to tell iPhoto to load the videos in QT X instead, but apparently not.

    If anyone knows a way to force iPhoto 08 to use QuickTime X I'd really appreciate it. Until then I'll just continue to right-click, "show file," then open in QuickTime X manually.
     

Share This Page