Can no longer play purchased videos

Discussion in 'Apple TV and Home Theater' started by Cave Man, Nov 22, 2009.

  1. Cave Man macrumors 604

    Cave Man

    #1
    Strange issue that I just noticed - I can no longer play my recently purchased videos from the iTunes Store. Purchased music plays fine - but no videos on my computer or Apple TV. Strangely, my older purchased videos play fine on both the computers and the ATV. I have the most recent versions of iTunes and ATV OS. I've tried deauthorizing all computers and reauthorizing but to no avail. Any ideas what might be happening here?
     
  2. tbayrgs macrumors 603

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #2
    Cave Man

    From what I've read on these forums, you seem quite knowledgeable and well versed so I get a bit nervous when something stumps you :eek:--went straight to my last video purchases to test and thankfully these are working fine for me.

    I certainly am no expert but happy to try to help you stimulate your thinking. Any recent changes to your system (new software, updates, hardware configuration changes, etc) that might coincide with when the problem started?
     
  3. lali macrumors regular

    Joined:
    Oct 14, 2007
    #3
    Cave Man,

    Same thing happened to me. After much fussing around I figured it out. I had originally bought some TV series with my U.S. account. I was now logged in my Itunes account using my canadian account. Doesn't work.

    I guess your original purchasing account info is embedded in the file. If you subsequently started a new account on Itunes and logged with that account, that file is no longer accessible. Anyways that was my problem, and no way around it, which is a pain.

    Lali
     
  4. Cave Man thread starter macrumors 604

    Cave Man

    #4
    Not sure what happened, but it has somehow "fixed" itself. Must be some Unix thing...
     
  5. sushi Moderator emeritus

    sushi

    Joined:
    Jul 19, 2002
    Location:
    キャンプスワ&#
    #5
    Glad that you brought this up.

    A few nights ago -- don't remember which for sure. None of my iTMS purchases worked. Then a few minutes later they did.

    Didn't think much of it when it happened. I figured that there was a password or Internet connection issue.

    But now that it's happened to you and a few others, I wonder if it has to do with some sort of background update at the iTMS?
     
  6. minik macrumors 65816

    Joined:
    Jun 25, 2007
    Location:
    Bellevue, WA
    #6
    How about using QuickTime Player?

    Recently, all my recent TV Shows purchases gave me a grey content when I hit play. However, they played normally on QuickTime Player X.
     
  7. Cave Man thread starter macrumors 604

    Cave Man

    #7
    I also tried QT Player but it had the typical gray screen. What was weird was that it wouldn't play on my desktop hackintosh or Apple TV, but played fine on my HTPC hackintosh and my MBA. It was about 2 hours before it started playing on the ATV, then I checked my desktop and it was fine on it, too. A strange problem.
     
  8. sushi Moderator emeritus

    sushi

    Joined:
    Jul 19, 2002
    Location:
    キャンプスワ&#
    #8
    That much is certain.

    If it happens again to me, I will be more observant and report the details.

    Last time, I figured it was just my computer so I did a restart and all was fine.
     
  9. emaja macrumors 68000

    Joined:
    May 3, 2005
    Location:
    Chicago, IL
    #9
    The same thing happened to me on both purchased and the digital copies that you get when you buy DVDs now. I have no idea what caused it, but when my ATV was not powering on I took it to the Apple store and they did a diag which found nothing, so they reset it. I took it home and it worked perfectly - and to my surprise the purchased content worked again.

    Not sure if it was a coincidence or not, but it may have something to do with the reset.
     

Share This Page