Can no longer print

Discussion in 'OS X Yosemite (10.10)' started by MBP*, Jan 25, 2015.

  1. MBP* macrumors member

    Joined:
    Jun 12, 2014
    #1
    I have a HP C4480, ironically, it was supplied with an old MacBook Pro I just finished with, with which the printer worked well. With this laptop I upgraded from Mavericks to Yosemite.

    I have my new 13" MBP with Yosemite, and trying to use the same printer. When I plug it in, it recognizes the printer, but ends up with 'unable to send data to printer' error every time. I haven't yet tried the scanner feature on the printer to see if that works.

    On the HP website, it simply says update it the driver through the Apple update, but there are no updates waiting to be installed.

    I've reset the printing system, but no luck.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Do you have a mac that isn't running Yosemite? Sounds like a driver issue, and yes they only come from Apple at this point, so you'l leave to wait and hope apple addresses the issue.
     
  3. MBP* thread starter macrumors member

    Joined:
    Jun 12, 2014
    #3
    I'm afraid not. The new MBP is my main computer. The only other way it seems that I can print is is through my Windows netbook. But then I'll have to configure a shared printer through the network.

    Is this a workaround - would I still need the driver on the mac to print to a shared Windows printer?
     
  4. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #4
    Try connecting the printer to a different USB port.
     
  5. MBP* thread starter macrumors member

    Joined:
    Jun 12, 2014
    #5
    Different USB port yields the same unsuccessful results.
     
  6. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #6
    That HP works fine on Yosemite - I'm using one.
     
  7. MBP* thread starter macrumors member

    Joined:
    Jun 12, 2014
    #7
    Yeah, it worked with my old Yosemite machine. Did you upgrade with Mavericks whilst it was in use?
     

Share This Page