Can no longer send emails in background in iOS4???

Discussion in 'iPhone Tips, Help and Troubleshooting' started by marcsorel, Jun 21, 2010.

  1. marcsorel macrumors newbie

    Jul 26, 2005
    Since I've upgraded to iOS4, I've noticed that emails don't seem to be sending the way they used to. If I compose an email outside of the Mail app (for example, sending a link to a web page from Safari) the email never sends unless I manually go into the Mail app's outbox folder, open the message again and then hit send from there.

    Is anyone else experiencing this? Is this really the way sending mail supposed to work now?

    (I should note that I'm using Google's Gmail Exchange Sync system here, but I don't think that's the problem. I can send email from within the Mail app very quickly as long as I wait for the sending sound to play before exiting or switching apps.)

    UPDATE: same issue using an IMAP account/and sending via SMTP.
    This is all kinds of horrible.
  2. aquapulco macrumors newbie

    May 4, 2010
    I just tested this on my 3GS with iOS 4 and it works perfect! Sent an URL from Safari and it was delivered immediately.
  3. marcsorel thread starter macrumors newbie

    Jul 26, 2005
    I'm glad to hear it's not a "feature" of iOS4. Now I just need to figure out why my emails are getting stuck in the outbox...
  4. marcsorel thread starter macrumors newbie

    Jul 26, 2005
    What kind of account are you using?
  5. sush macrumors newbie

    Jun 14, 2009
    I have the exact same problem using Gmail active sync
    Works with my Gmail imap account though
  6. marcsorel thread starter macrumors newbie

    Jul 26, 2005
    I seem to have fixed mine this AM by deleting my active sync email account, force-restarting the phone (not sure if that really did anything) and then re-adding the account. When adding the account I hit cancel and started over if it said it was unable to verify, so I had to try 5 or 6 times.

    Eventually though it went through and things seem to be sending normally now. Mail is still a little slow to arrive/push, but hopefully google will fix it soon.
  7. bushbaby macrumors 6502


    Aug 12, 2007
    I can't send mail from my POP accounts. It wants a password but I've already put in the password to receive mail (and that works). Cannot see a separate place for a password to send mail.
  8. sush macrumors newbie

    Jun 14, 2009
    That didn't work for me unfortunately.
  9. Kuzminator macrumors newbie

    Feb 1, 2008
    Salem, OR
    I have the same problem and I'm using google exchange.
  10. rmchale macrumors regular

    Jun 22, 2009
    I have this problem and have had it through the beta. I constantly forget to "send" messages because they land in the outbox.
  11. Dagobah macrumors newbie

    Jun 29, 2010
  12. iThinman macrumors regular

    Jun 27, 2010
    Passwords do not carry over with a restore. You may need to go into the properties for each account and not only set the password on the initial screen, but also in the smtp server settings screen for each.
  13. rmchale macrumors regular

    Jun 22, 2009
    Exchange does not have these settings.
  14. lindenmeng macrumors newbie

    Jun 29, 2010
    There are many producs in the market ,but according to the use frequency,this

    product is the best choice, I bet you will have a suprising result,just have a try!
  15. BadaBing!! macrumors 6502


    May 16, 2010
    I had the same problem where mails sent from apps other than the Mail App were stuck in the Outbox until I manually send them.

    I was using google Sync for Mail, Contact and Calender + Google IMAP for Notes sync.

    I fixed the problem by removing the IMAP Account (used only for Notes) and reset network settings.

    It's now OK. But I whish Apple will fix so I can start Notes Sync again.
  16. boxstboy macrumors member

    Jul 25, 2009
    I found a solution to this problem without losing your Notes sync.

    If you have both a Gmail exchange account for push Gmail and an IMAP account for Notes sync to Google as well, you have to turn on mail in both accounts.

    Go into Setting, Mail, and turn on Mail for both the Exchange and the IMAP account. Then go down on that screen to where it says "Messages created outside of Mail will be sent from the default account. You can then select the Exchange account as default and they will send immediately if you email something outside of Mail.

    The only problem is that it creates two identical email accounts in your unified Inbox. However, you can just use the Gmail Exchange inbox to avoid duplicates.

Share This Page