Can no longer symbolic link user library folders in Mavericks

Discussion in 'OS X Mavericks (10.9)' started by Demigod Mac, Oct 23, 2013.

  1. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #1
    In Mountain Lion I had a nice little system going between my SSD and HDD. I created symbolic links for my Documents, Pictures, Movies, Music, Downloads folders and it worked perfectly. However in Mavericks it looks like you're not allowed to delete these folders and replace them anymore...

    "Downloads" can't be modified or deleted because it's required by OS X.

    Bummer.

    I'll look into it some more tomorrow to see if there's a workaround, but if anyone's already tackled this issue, do let me know.

    P.S.
    Would really rather not split my user folder locations via the hidden option. Tried it before and it had too many issues and annoyances.

    ----------

    Follow up thought...

    I could probably hit the normal folders with a chflags hidden Terminal command and then fill the Home directory and Finder sidebar with the symbolic links, although this would be a somewhat clumsier solution than what I had going in Mountain Lion. It would be awkward when apps that default to the Documents folder settle on an empty folder.
     
  2. nihilisticmonk macrumors 6502

    nihilisticmonk

    Joined:
    May 4, 2005
    #2
    Thanks for posting this. I have the same setup on my 17" MBP with a 64GB SSD and 500GB HDD.

    I'll hold off upgrading for now until some braver soul than me figures this out.
     
  3. nihilisticmonk macrumors 6502

    nihilisticmonk

    Joined:
    May 4, 2005
    #3
    Actually, my method still works fine


    Davids-MacBook-Pro:~ notarealuser$ sudo rm -rf Downloads
    Davids-MacBook-Pro:~ notarealuser$ ln -s /Volumes/Macintosh\ HD/Users/notarealuser/Desktop/Downloads
    Davids-MacBook-Pro:~ notarealuser$

    Is this the method you were saying you've had issues with previously?
     
  4. Demigod Mac thread starter macrumors 6502a

    Joined:
    Apr 25, 2008
    #4
    Creating symbolic links still works, it's replacing the folders with the links that doesn't seem to work anymore.
     
  5. robgendreau macrumors 68030

    Joined:
    Jul 13, 2008
    #5
    Is it a matter of the right privileges?

    What are the current permissions?
     
  6. jhfenton macrumors 6502a

    jhfenton

    Joined:
    Dec 11, 2012
    Location:
    Norwood, Ohio
    #6
    I'm with nihilisticmonk. I haven't seen a problem with my symbolic links. My Downloads folder is on an external drive with a Terminal-created symbolic link in its place. And I have the same setup with my iTunes media folder.
     
  7. Demigod Mac thread starter macrumors 6502a

    Joined:
    Apr 25, 2008
    #7
    Solved.

    Had to log in as Root, delete the folders and name the symbolic links the same.

    So far so good.
     
  8. gizmo74, Oct 30, 2013
    Last edited: Oct 30, 2013

    gizmo74 macrumors newbie

    Joined:
    Oct 30, 2013
    #8
    Symlinks not working in ~/Library/Application Support

    I'm hoping someone here can help with my sym link problems...I have run into a brick wall very similar to the start of this thread. I don't sym link all of my folders; however, I do sym link folders that have personal information in them (individual folders for Mail, Contacts, etc.).

    After upgrading to Mavericks, all I wanted to do was get my Contacts working...the data resides in ~/Library/Application Support/AddressBook. In ML, my sym links worked perfectly (I had them linked to a TrueCrypt container at /Volumes/SECURE/AddressBook).

    Now, with the same links in place (and re-created multiple times), Contacts opens up with *zero* contacts...adding my iCloud account doesn't work; and adding any imaginary contacts, closing, and re-opening does not save said imaginary contacts (application opens up to *zero* contacts again, as if it didn't have permissions to write to the file).

    Thinking it might be something with the TrueCrypt interface, I even tried creating an Apple encrypted file sparse image (on my desktop), and just plain out putting the AddressBook directory unencrypted on the desktop. Sym linking from ~/Library/Application Support to these directories failed in the same way described...it appears Contacts can't read sym links!?

    I've also verified all the permissions for the links and target directories...everything is on the up and up...but the Contacts app refuses to cooperate.

    I've posted a detailed post on Apple's support site, but it does not seem to be getting any traction.

    When checking my Console, this is the error causing Contacts to choke:
    (this file is the exact name of my sym link, and the name of the directory that Contacts *should* be reading).

    Immediately following this error, there are a couple "could not create the store" and "error reading attributes at path" that appear to be chained to the initial source folder log entry.

    If anyone has any suggestions, please let me know...every day that goes by I am losing productivity, and I'm getting ready to just bite the bullet and go back to ML...but I don't want to!

    Thanks in advance :)
     
  9. Eugene El macrumors newbie

    Joined:
    Dec 20, 2013
    Location:
    Ukraine (unfortunately)
    #9
    How did you solve this problem?
    I want to move cache folder for safari and opera to the external drive.
    Is it possible in OS X 10.9?
    Where can I find full instruction how do to it with symbolic links?
     
  10. 409industries macrumors newbie

    Joined:
    Feb 11, 2014
    #10
    I too have run into this problem and am trying to figure out a work around. I have some Mac users that we need to change the location of their "Documents" folder to a network share. This is something that we've had in place for a very long time and want to get working with Mavericks as well.

    The share as been symlinked via the same method that Demigod mentioned, but in the Finder > Preferences > Sidebar with "Documents" checked, we do not get the link in finder visible on the left side.

    Is this even possible to do? I would settle for some kinds of manual entry in the side bar if we can make sure it mounts the network share on boot and connects every time.

    stumped. Looking for help! Thanks.
     

Share This Page