Can not access Files via AFP as Guest

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Don-Marcus, Jun 16, 2008.

  1. Don-Marcus macrumors newbie

    Jun 16, 2008

    I need help with some problem.
    I want to share my public folder inside my home folder with my environment. So I added the public folder to my shared folder in the system preferences "File Sharing". In the Users preferences I made the guest account to have the rights for only file sharing. In the firewall preferences the access is only allowed for certain programs and utilitys. In the list at the bottom there is also listed the AFP.

    When I click on my Computer from another one in the Finder I can see my computer and I am logged in as Guest suddenly but I can not see any folder.

    I'm using the latest Leopard.

    Does anybody know what I am doing wrong?

    Thank you very much for advice!

  2. ajjmcd macrumors newbie

    Jul 6, 2008
    Hi Marcus.

    Your firewall: you mention 'certain programs and utilitys' - sorry, but do you mean 'specific services and applications', or 'only essential services'. I have selected 'specific services and applications' on my Mac.

    In your finder: although the computer you want to access will appear on your sidebar, and it may indicate 'Guest', access still has to be authorised or established for any communication to take place. It sounds like you've set File Sharing and FTP to 'On'; yes? :)

    Does the 'Connect as' button appear on the top right hand side, below the search box? If so, click on that button and it will offer a choice of 'Guest' or 'Registered User'; the latter will be an assigned user on the remote computer.

    Guest will not require a password, but will only have the access that you have set up, i.e. a Shared folder. If you set the guest up as a registered user on the computer you are allowing access to, then access is can be set to filter through your folders according to the user permissions, rather than setting permissions in each individual folder.

    If the 'Connect as' button isn't there, then something else has been missed whilst configuring your firewall. I recently wanted to establish Screen Sharing with an old iMac running 10.4, and although I knew everything was set up fine with my MacBook Pro (having shared screens with another Mac), it turned out that the firewall on the 10.4 iMac did not have the default option to permit traffic on port 5900 which allows Remote Access/screen sharing. I added a custom port permission, and it worked fine. But I still don't know why the 5900 port access was absent, when it was present on another 10.4 configure Mac by default. The ports for file sharing are 548 & 427; FTP sharing goes through port 21.

    Let me know how you get on; I've had issues like this with a variety of Macs, but it has always worked out in the end!


Share This Page