Can not boot into OSX - might contain some silly questions

Discussion in 'macOS' started by kanketsu, May 4, 2008.

  1. kanketsu macrumors member

    Joined:
    Jun 15, 2007
    #1
    Hi all,

    I believe I'm in trouble, although I'm not sure how big it is. A couple days ago, after noticing the bluetooth icon on the menu bar crossed out or something, I restarted my Macbook (it's 10.5.2.). However I can not boot into OSX - just the white screen with Apple logo.

    The local APR guys suggested to use the installer DVD to run Disk Utility. So I inserted the original installer (10.4.10). The "repair disk" option worked, it told me that something minor needed to be fixed (and it has) but I can't choose the "repair disk" option. It said something like "no valid package".

    Does it mean that I need to run Disk Utility from the Leopard DVD? Which is a problem, since I don't have it with me right now.

    I don't know if this will work, but suppose I have a Fire Wire cable and connecting my Macbook to another Mac running Leopard, will I be able to run Disk Utility from this other Mac to repair disk permission on my macbook?

    I wish I had an external FW drive with bootable clone..
     
  2. beatsme macrumors 65816

    beatsme

    Joined:
    Oct 6, 2005
    #2
    yes, that will work. Connect the Macbook (while it's turned off) to the other Mac with a firewire cable. Start up the Macbook in Target Disk mode, and it should appear as a mounted drive on the other Mac. Then you could repair disk permissions using the other Mac's Disk Utility feature.
     
  3. kanketsu thread starter macrumors member

    Joined:
    Jun 15, 2007
    #3
    Thanks for the reply. BTW, how likely is it that repairing disk permission will solve the boot problem? Should I keep my expectation low?
     
  4. beatsme macrumors 65816

    beatsme

    Joined:
    Oct 6, 2005
    #4
    it's hard to say. You might be looking at a re-format and a re-install, but if it were me I'd definitely try this first.
     
  5. beatsme macrumors 65816

    beatsme

    Joined:
    Oct 6, 2005
    #5
    what you might try, too, is to reset the SMC

    http://docs.info.apple.com/article.html?artnum=303319

    worth a shot.
     
  6. kanketsu thread starter macrumors member

    Joined:
    Jun 15, 2007
    #6
    Ouch.

    Okay, I'll do that.

    I'm a bit confused though, how come that the supposedly stable OSX can crash like this? I mean, it was working just fine for 7 months but for no apparent reason.. snapped at once. As if there were some system-related files suddenly went MIA, thus the eternal boot.
    :confused:

    7 years with that other OS, never got something close to this.:)

    (I took a peek when the local APR guys "diagnosed" the Macbook - it seems that the screen kept displaying the same text lines over and over again. One guy mumbled, "It keeps reporting self-crashed report?" (or something like that).
     
  7. kanketsu thread starter macrumors member

    Joined:
    Jun 15, 2007
    #7
    Up & Running Again

    Problem solved.

    What I did is set my friend's Macbook as an external FW Drive, and boot my Macbook from there. Run Disk Utility to repair the HD's disk permission, and everything's back to normal.

    I still don't know what the cause of the problem is, but while repairing disk permission, it was displaying many lines, something like:
    "blah/blablahablah/blah.plist user number is supposedly 0, it was 501."
    over and over again (different blahs but same 0s & 501s).

    After successfully booting into OSX, I opened the console and found that apparently something were crashing the login window over & over again. Not sure what caused it.

    But well, everything seems good now. Thanks for the support:D
     

Share This Page