Can not eject CD from Apple Super Drive

Discussion in 'OS X El Capitan (10.11)' started by kat.hayes, May 4, 2016.

  1. kat.hayes macrumors 6502a

    Joined:
    Oct 10, 2011
    #1
    Using a new iMac with El Capitan and a Apple USB Super Drive, I have an old CD in the drive and sometimes when I boot the iMac the CD shows on the desktop and sometimes it does not. I have tried Command + E, rebooting while holding the left mouse button, I have opened Terminal and typed in drutil tray eject

    and none of this works. When I was able to access the disc, it had lots of photos on it that would never open, and when I tried to open an image or copy it to the desktop, it would just crash the Mac, the spinning wheel would come up and relaunching Finder would just result in me having to cut the power and reboot. I want the disc out, I plan on cutting it in half, I gave up on the data, I hate old CDs because many of them seem to do this when accessing them on my Mac. I just need to get the disc out.

    Anyone have any ideas?

    Thanks.
     
  2. Polyphonie macrumors member

    Polyphonie

    Joined:
    Nov 17, 2013
    Location:
    Toronto
    #2
    If you have access to a MacBook- restart the MacBook (with the SuperDrive connected) while pressing on the trackpad (the bottom part of the trackpad).

    Or it might also work if you have a wired mouse or a wired Apple keyboard. On the Apple keyboard, you can restart the iMac and keep pressing on the eject button.
     

Share This Page