Can not import into iPhoto

Discussion in 'Mac Apps and Mac App Store' started by beaker314, Oct 5, 2011.

  1. beaker314 macrumors newbie

    Joined:
    Oct 5, 2011
    #1
    I am on my honeymoon and trying to import photos into iPhoto so I can get them off my camera. I always get an "unrecognized format" error even though the files open fine in Preview, Gimp, and Photoshop. So far I have tried:

    1) Copying the files onto the hard drive then importing
    2) Importing files not from my camera (Random photos from websites in jpg or png formats)
    3) Creating a new library (Holding down Option when starting iPhoto)
    4) Deleting all relevant plist files.
    5) Rebooting
    6) Yelling at computer


    So far, none of these have worked. If anyone has any more suggestions, please let me know. I have a feeling the issue may be that I had to restore from a backup about a month ago and perhaps something was not installed correctly.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Post MAke, Model And Format Of camera

    Yelling, won't help!
     
  3. beaker314 thread starter macrumors newbie

    Joined:
    Oct 5, 2011
    #3
    Camera: Canon PowerShot SD890

    I do not think the camera type actually matters, but the make is Canon PowerShot SD890. I am unable to import any image files at all, not just the ones from my camera. For instance, I saved the logo and a number of other images from this page and all of them gave the same error when I tried to import them (They are png and gif files)

    And yes, I know that yelling wont help... at least until Siri is added to OSX! :)
     

Share This Page