can not install certain software due to privileges issue..

Discussion in 'Mac Apps and Mac App Store' started by wout, Oct 19, 2005.

  1. wout macrumors newbie

    Feb 11, 2005
    Hello all,

    I have been thorougly searching the internet(incl this forum) but can't come up with a solution for the following.
    I've been using my eMac 1.25 GHz PowerPC G4 512 MB DDR SDRAM with Mac OS x 10.3.9 for about a year now, without even the slightest problem.
    So, I guess it was time for the first one..

    Dreamweaver was behaving oddly(starting up, bouncing in the dock and then just quitting) so I decided to reinstall it.
    When reinstalling however, I got the following message after entering the correct admin password : "the software to be installed requires Administrator or higher level access privileges."

    I am confused because:
    - I entered the correct password(certain of this)
    - I am the only user and the administrator(double-double checked that)
    - I repaired all the disk permissions using Disk utility

    Never had this problem before and I obviously installed Dreamweaver before. Could it be because I used System Optimizer X the day before?
    Also tryed reinstalling my Adobe Creative suite and I got the same problem..
    This person had the same problem, but his solution didn't work for me:,14055164

    :) anyone who could offer any help would be very much appreciated,

  2. screensaver400 macrumors 6502a

    Jan 28, 2005
    Try making a new admin-level account, and install it from there.

    If that doesn't work, set up the Root account, and install it there.
  3. yenko macrumors 6502a

    Aug 29, 2005
    Try putting the app in the trash (don't empty the trash) and then restart the machine. Try installing the software.

    When you're finished, empty the trash.
    See if that works.
  4. wout thread starter macrumors newbie

    Feb 11, 2005
    can not install certain software due to privileges issue..2

    Thank you very much for your time,
    however I've tried the above and it didn't work..
    i'll browse the internet some more,
    meanwhile any more suggestions would be appreciated.
    if all else fails i'll take it to the Mac store where I bought
    my mac...
    it's a shame it's my first major unsolvable issue with a Mac.
    still, it's a lot better than Windows.
  5. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    You might try going into your user area, opening the Library folder, then Application Support, after which you should move the Macromedia folder to the trash and try to empty the trash prior to trying the installation again.

    You should also look for a folder Macrovision, if that doesn't work and you have any of the Studio MX 2004 applications installed.
  6. wout thread starter macrumors newbie

    Feb 11, 2005

    The problem is solved! I removed macromedia and all it's library folders and reinstalled it in root user mode, as suggested in the first reply to my post. This worked like a charm! Although it isn't ideal ofcourse because it ought to work in my normal administrator mode as well. Whatever the case, macromedia studio is now working again and i couldn't be happier! Thank you all for replying and helping me in solving this problem!

    @bousozoku : i did find the macrovision folder but decided not to mess with it, since the apps are working now, but it includes some kind of authentication service.. thanx anyway)

Share This Page