Can not kill programs

Discussion in 'Mac Basics and Help' started by oldmanmax, Mar 26, 2008.

  1. oldmanmax macrumors member

    Joined:
    Nov 8, 2005
    Location:
    Upstate NY
    #1
    I am starting to have some issues with my 4 year old G5 PPC 2.0, programs will finish, but won't let me shut them down(Toast, quicktime, Safari, p2p programs). They stay on the dock and I can not use them. Can't force quit or remove from dock. DVD burner will show 50% complete on verification, but disk is done, and then won't let me burn anything else, tried burning with disk utility and just get the rainbow wheel after starting it up. Safari locks up and just sits there. things are just hanging and can't do anything with them except shut the machine down and start over. Hell it's like I have a PC instead of a mac.

    Machine is a G5 PPC, dual 2.0, gig and half ram, two internal 160 gb hard drives and two 250 externals. Running leopard, 10.5.2 with all updates. Have done a disk repair on all 4 drives and only had one issue with the DVD writer recognition and it was fixed. Have not had any kernel panics. Machine bought in July of 2004. No issue's until this last week and half. Any help will be appreciated on what to try to fix these issues
     
  2. j.bond312 macrumors newbie

    Joined:
    Jan 30, 2008
    #2
    Have you tried opening terminal and using the 'killall' command?

    For example 'killall Safari'

    See how that works for you, does seem a bit odd though that its more than one app that isnt shutting properly
     
  3. OldCorpse macrumors 65816

    OldCorpse

    Joined:
    Dec 7, 2005
    Location:
    compost heap
    #3
    Can't offer a solution to your problem, but I can offer sympathy and understanding. This happens to me, though slightly differently, and it's irritating as heck. Namely, for me, often the command "Force Quit" just does NOT work. What's up with that? I have to go to Activity Monitor to kill apps sometimes (often a browser, Safari or FF, but really a lot of apps). I thought one of the points of the unix underpinnings of OS X was that you can kill a process absolutely. Well, you can't - at least not using the GUI (from the dock)... I don't want to drop to CLI when the specific command is a standard option in the GUI. I'm really disheartened by a lot of OS X promise transpiring to be empty... more and more it's starting to resemble Windows, where you never know if something'll work or not. Force Quit should absolutely kill a process, no ifs, buts or maybes. Instead, it's just a pretty "option" with no substance behind it. Feh!
     

Share This Page