Can not publish to YouTube from iPhone 5

psychonaut

macrumors 6502a
Original poster
Jul 24, 2008
524
4
Need some help here please. No matter what I try doing I can not publish videos to YouTube from my iPhone 5.

I have a 3min video and going into my photo album from the iPhone I select the publish to YouTube option. I have logged into my account, it prepares the video and says its starting the upload but then fails with the error "Could not publish"

If I log in to YouTube from my desktop I can see the video in my pending videos but of course it has not been uploaded so its only the title not the content.

I am doing this all over WiFi and trying to upload in HD.
 

psychonaut

macrumors 6502a
Original poster
Jul 24, 2008
524
4
FYI - After doing a lot of searching I fixed this problem.

Strange solution - film a very short video (3 seconds) and upload via the iPhone which worked!

From there I am able to upload any other video including the 3min video I was having issues with.
 

othmuse

macrumors newbie
Feb 20, 2013
5
0
I'm having this issue on my Verizon iPhone 5. Everything I try to upload, no matter what length, HD or standard. I get a "Could not publish _____ to YouTube" box.
 

Ropuh

macrumors newbie
Mar 16, 2013
1
0
The same here. I tried on iPhone 5 and iPad 4 and alwas the same "Could not publish!".