Can not scan using Networked HP 3210 through Time Capsule

Discussion in 'Mac Accessories' started by mekump, Jun 25, 2010.

  1. mekump macrumors newbie

    Joined:
    Jun 25, 2010
    #1
    I have a HP photosmart3210 connected to an Airport Express via an ethernet cable. Printing works fine, just can't scan from my Apple computers or my PC. I have all the latest sw updates installed. My iMac is running 10.6.4 and my MacMini is running 10.5.? with HP software installed. My PC is running winXP sp3 with HP software installed.

    My network - cable modem ---> time capsule via ethernet cable. Time Capsule handles dhcp. Wireless computers and Airport Express communicate via wireless to the Time Capsule. Time Capsule "Connection Sharing" = "Share a Public IP Address"

    When I had DSL, I had a DSL modem/router that took care of the dhcp and routing. The Time Capsule parameter "Connection Sharing" was set to "Off (Bridge Mode)". With this setup my scanner worked.

    I tried turning off the PC and Apple computers firewall but that didn't make a difference.

    Does the Time Capsule have some sort of built-in firewall? Something that would block my scanner requests?
    I wouldn't think my cable modem would have anything to do with printer/scanner.

    Does anyone have an HP AIO Printer connected to the TimeCapsule via an ethernet cable or wireless? Are you able to scan from SL 10.6.4? If so, what do you have the parameter "Connection Sharing" set to?

    I've tried everything I can think of. Still can't scan from my Apple computers or my PC.

    thanks,
    mike
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Its been my experience that the ability to scan wirelessly is entirely separate from the ability to print wirelessly. Because of the amount of data that has to be shared between the scanner and the computer, a USB connection is the best means, not over WiFi. This is as opposed to printing where you computer just shoots off a command and the printer implements it; it doesn't have to send anything back to show up on the computer screen like a scanner does.
     
  3. mekump thread starter macrumors newbie

    Joined:
    Jun 25, 2010
    #3
    Thanks for your reply.

    As part of my troubleshooting, I connected the HP to the TC via an ethernet cable and still could not scan. I guess I could try connecting a laptop and the HP to the TC via ethernet cables and try again.

    The thing I don't understand is, I used to be able to scan from my PC with this setup when I had a DSL modem connected to the TC and the TC was set to "Bridge mode". I lost the abililty to scan when I changed from a DSL modem to a cable modem and set the TC for "Share a public IP address".

    The DSL modem was a modem/router while the cable modem is just a modem with VOIP for my phones.

    I'll report back with the results from my testing above.

    All suggestions or ideas are welcomed in helping me resolve this issue.
     
  4. mekump thread starter macrumors newbie

    Joined:
    Jun 25, 2010
    #4
    I tried the following and still could not get the HP scanner to work.

    Connected the HP to the TC via an ethernet cable.
    Connected my laptop to the TC via an ethernet cable. Same error as before.

    Also tried my mac mini directly connected to the TC. Same error as before.

    Apple laptop is running 10.6.4
    Mini is running 10.5.x (whatever the latest is) with HP s/w installed.

    I don't know what else to try. I guess the photosmart 3210 doesn't work with the TC, wired or semi-wireless.
     

Share This Page