Can not un-mount anything

Discussion in 'Mac Basics and Help' started by oursfan, Dec 17, 2007.

  1. oursfan macrumors member

    Joined:
    Nov 28, 2007
    #1
    I tried to search the forums for an answer to this but have not really found any straight forward answers. I am not a computer genius so the simpler explanation the better for me.

    I upgraded to Leopard a few weeks ago and really like it. However, just the other day I started having this problem. I can not eject or unmount anything anymore. I can not eject my external hard drive or any other .dmg programs downloaded from the net. They just sit there. I have tried ejected them using the icon next to them in the device panel and I have dragged the icon to the trash. The only thing that works is if I go to disc utility to eject them or simply restart my computer. Does anyone know why this started happening all of the sudden?
     
  2. Fleetwood Mac macrumors 65816

    Fleetwood Mac

    Joined:
    Apr 27, 2006
    Location:
    Canada
    #2
    Its hard to say. Try making a new account, mounting something and then un-mounting it. Tell us what happens.
     
  3. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #3
    Just to confirm -- no open windows or apps running associated with those dmg's? Did you update to ensure you're using the latest update package for Leopard?

    If Y to both, this is perplexing and I'd like to know the results of "Fleetwood Mac's" suggestion, also.

    -jim
     
  4. Jeremy! macrumors newbie

    Joined:
    Dec 14, 2007
    #4
    They won't unmount if they are being used. Perhaps they are being indexed? Or permissions are wrong. Trying doing an info (command I or 'get info' from the finder's file menu) on the volumes to see what the permissions are.
     
  5. oursfan thread starter macrumors member

    Joined:
    Nov 28, 2007
    #5
    Well, whatever was going wrong has apparently corrected itself because things are back to normal now. I can not really explain what happened or why it is now working, but I can un-mount things again. If the problem comes back I will update the thread. Thanks for all the advice.
     
  6. compuwar macrumors 601

    compuwar

    Joined:
    Oct 5, 2006
    Location:
    Northern/Central VA
    #6
    When you plug in a new drive, Spotlight starts indexing it, and if you don't stop it, then you can't unmount the drive until Spotlight is done indexing. You'll see the pulsing dot up in the right corner.
     

Share This Page