Resolved Can only access gmail/facebook

Discussion in 'Mac OS X Lion (10.7)' started by gslee84, Aug 13, 2012.

  1. gslee84, Aug 13, 2012
    Last edited: Aug 13, 2012

    gslee84 macrumors newbie

    Aug 13, 2012

    I was trying to delete some unnecessary user preferences and must've been a little overeager - now I can't connect to any website that's not gmail/facebook.

    - Not my browser - Chrome, Safari, Firefox yield the same issue
    - Not a wireless issue - plugged into ethernet, same issue
    - Not my network connectivity - can still access internet through other programs like iChat/Skype, (and still get updated gmail/FB)
    - Not my user profile - tried a different user profile, same issue

    Downloaded data rescue/disk drill to see if I could see what files I deleted (but would have to pay to recover the actual files), and some files that look relevant/important -


    Don't want to have to:

    1. pay for data recovery programs and hopefully recovery the files that allow me to access other websites,


    2. reset my macbook pro to factory settings.


    - can't access app store to re-download lion (10.7.4) or even mountain lion.
    - never used timemachine.

    Any ideas? Thanks in advance.
  2. r0k macrumors 68040


    Mar 3, 2008
    First of all, you need a Lion recovery USB stick for future use (not necessarily to solve this problem). I suggest you solve your "can't access app store" problem and get that done.

    Secondly, create a "spare" user account. Log in and see what web pages you can see. I suspect they will all work just fine. You could use this second user account to log in to the app store and nab yourself a backup copy of install osx so you can make yourself a recovery usb stick (for future use).

    If a second user account doesn't solve this issue, then perhaps it is related to some network setting. One common network setting that can "kick you off the internet" very quickly is DNS. I suggest putting google's DNS in your network configuration either on your Mac or in your router. One of their DNS servers is and the other is

    Hope this helps...

Share This Page