Can only use email adresses for iMessage on 4S

Discussion in 'iOS 6' started by 6825924, Jun 9, 2013.

  1. 6825924, Jun 9, 2013
    Last edited: Jun 9, 2013

    6825924 Suspended

    Joined:
    Aug 13, 2012
    #1
    Hi
    My iPhone 4S won't accept my phone number to send and receive messages only my email adresses can be used. I have no problem with my phone number on my iPhone 5, nor on my MacBook or iPad...
    How is this possible?

    Thanks
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    Mine was doing that the other day and the solution was simply to turn iMessage off and back on. Have you tried that?

    Also, you may want to blur your details out of that picture.

    Edit: I just noticed that it says "No SIM". I don't know whether it works without one or not...
     
  3. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #3
    it should work without a SIM, provided the Apple ID is associated with an active phone.

    my ipad and ipod both allow me to activate imessage with my phone number as an option. i would try turning imessage off and on again. is this phone being used on wifi only or does it have an active cellular account.
     
  4. Blaine macrumors 6502a

    Blaine

    Joined:
    Dec 3, 2007
    Location:
    Abilene TX
    #4
    I have the same issue with my old decommissioned iPhone 4S. I use it as a glorified iPod touch. Someone said when you use an iPhone in this manner (no active cellular plan), it will only let you use your apple ID. Maybe iOS 7 fixes this?
     

Share This Page