Can ping but not browse (intermittent)

Discussion in 'macOS' started by sheckylovejoy, Aug 12, 2011.

  1. sheckylovejoy macrumors newbie

    Joined:
    Aug 12, 2011
    #1
    Here's a doozy I've been struggling with the last 2 weeks. Just moved into a new place and got the same Time-Warner Internet service as in the old place. Sometimes the connection is very fast, but then at others I cannot even connect to a website. However, at the same time I get nothing in the browser, I can ping the same site with little or no packet loss. Then magically, it will work fine for a few minutes, before dropping out again.

    I've tried just about everything. I have 3 Macs here (2 Mac Pros and a MacBook Pro). All experience the same problem. Time Warner has been out here 3 times and replaced all the cable and modem/router. They say they've done everything they can do. One of the Mac Pros only has a clean install of SL with no settings changed. All computers have had their wireless and wired tested elsewhere and are working. This happens with safari/chrome/firefox, wired and wireless. I've even booted into boot camp and no luck in windows either.

    Remember at the same time, I have an genuine IP address from Time Warner and I can ping at will, both to the router and to any URL I like

    Tried Google DNS

    Tried fresh install/clean user

    Here's some more weird stuff:
    • one thing that seems to kill the internet is multiple connections being opened. E.g., multiple tabs or checking mail with mail.app on all 8 email accts or a page with lots of images or flash movies (that is to say, lots of objects to load). I can watch the logs and see that pages with lots of items rarely fully load.
    • two things seem to knock it back online sometimes
      1. starting some pings in Network Utility and
      2. switching between wired and wireless. Neither always works.
    • while all 3 Macs choke, iPad and iPhone work really fast here!

    Help!
     
  2. basher, Aug 12, 2011
    Last edited: Aug 12, 2011

    basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #2
    Could your router have been damaged in your move?

    I had strange connectivity issues like you described and it turned out to be a bad Ethernet cable. Now I realize the chances of having bad multiple Ethernet cables is remote, but it might be just another thing to check.

    If you are running Internet connection sharing, lots are reporting that it's flakey/broken.
     
  3. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #3
    When I read the OP carefully, it appears to me that all three of these have already been ruled out.

    1 - iphone and ipad work fine. this rules out a problem with the cable coming into your house and appears to rule out a problem with the cable modem and router - for wifi.

    2 - wired and wireless attempts to connect with anything (whether os x or windows on Mac hardware) are intermittent.

    I don't know if Time Warner is as clueless as Comcast but I once had Comcast techs at my house all day and they went through 6 cable boxes before they found one that even worked. From your post, it sounds like the cable company provides a router with the cable box? If it's a Motorola RoadRunner cable modem, you can see the cable modem's setup page (and reset it remotely) by visiting 192.168.100.1 regardless of how you have your internal IP address pool set up. Look for things like failures and signal losses in the cable modem's log. If those events show up since Time Warner replaced all the wires, you can demand they come back and make it work "for real".

    I would be inclined to dump the router provided by the cable company and plug an airport extreme directly into the cable modem. At our house, I've been through about half a dozen routers. Finally after going with an Airport Extreme, I don't have to trudge down to the basement several times a month to unplug and reset the cable modem and the router. At most I have to unplug the cable modem about every 60 to 90 days. This is a vast improvement over the situation when I was using Zyxel, Linksys, Negear and Dlink routers. Yes I tried quite a few over the years. I upgraded from a Time Capsule to an AEBS to get the "guest network" capability and I'm lucky I did as the TC power supply died a couple of months afterwards. The Time Capsule was the first router I had tried that almost never needed to be reset. The AEBS is the first one I've tried that literally never needed to be reset. I would have been without internet waiting for Apple to replace my TC if I had kept using the TC as my router. Anyway, to return to your situation, perhaps it is worth giving an AEBS a try. Apple has eliminated restocking so you can give it a try and if it's no better than the router from Time Warner you can simply return it. The down side of using an AEBS is you have to configure it in Airport Utility rather than with a web browser.

    BTW, I suggest putting google dns (or anything but your ISP dns) in your router's settings so it sets up dns properly with every client that connects. There is a difference in the way dhcp works on iPhone/iPad vs desktop Macs. I suggest you get rid of any DNS settings you have in your PCs and let the DNS come from the router. Then you are only debugging one "flavor" of DNS issue rather than trying to remember which machine is pointing at which DNS (google, opendns, time warner, etc). BTW, as I mentioned earlier I don't recommend using your ISP's DNS. One problem I have had with Comcast over the years is their DNS goes down at inopportune times. The symptom is the same. I can ping IP addresses but if I try to ping a domain it never gets resolved. For a while, I had yahoo's ip address in Terminal from previous pings during DNS outages and could simply up arrow to ping it again. Happily those commands have scrolled off the stack of terminal commands as I haven't had DNS outages in over a year.
     
  4. sheckylovejoy thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #4
    Thanks both to basher and r0k for such prompt and thoughtful replies!

    I'm going to respond to both together here in handy bullet-pointed fashion:

    • Ruled out ethernet cables and ethernet hardware? Used working cables from previous location, as well as brand new Cat6. Tested all three systems on another home network.
    • Ruled out wireless? All computers are within 10 ft of router with line-of-sight. All computers tested on another home network. Signal is strong according to KisMAC.
    • Ruled out router? Brand new (shrink-wrap and all) Netgear CGD24G Gateway from TWC (and yes they are tools as big as Comcast). Have also tried 2 different Airport Extremes (UFO and current model) as well as an 802.11g Airport Express. I will try monkeying around on the setup on the Netgear; I kept meaning to do it, but I am more inclined to throw it through a window at this point
    • Ruled out settings (esp. DNS)? One test machine has a fresh install of 10.6.8 with nothing else. Tried with Google DNS, OpenDNS as well as TWC DNS (also goes down a lot like Comcast, though it's gotten much better in the past year).
    • Ruled out TWC sucking ass? Never possible, but they did bring me a brand new gateway/router and I saw all the OLD (and I mean OLD) cable they pulled out of my walls
    Here are the central issues that make no sense to me:

    • I can see the internet can see me (pings show little or no packet loss). It seems like they just stop talking for extended periods. Example: I'm looking at Reddit and all of a sudden, an imgur page won't open. I immediately open ping and ping imgur -- successful with good turnaround times. I open the Macbook Pro -- sometimes it will open the link, sometimes not (usually not, but not 100% of the time). I go to the iPad -- that works, every time so far. WTF?
    • The problem seems to have something to do with multiple connections. Does this suggest anything? I can't imagine what.
    • That being said, I can sometimes go a couple of hours with very high-quality internet service.
    My task today is a little router mojo. Pray for me, I am a man on the edge.
     
  5. jaymdubbs macrumors newbie

    Joined:
    Oct 10, 2011
    #5
    major bump

    I'm having this exact same issue on my mac mini and macbook pro - any resolution to this?
     
  6. sheckylovejoy thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #6
    It was a problem with Time-Warner modem/router (Netgear CDG24G Gateway). Turning off its firewall solved the problem.

    http://text.dslreports.com/forum/remark,26325189
     
  7. jaymdubbs macrumors newbie

    Joined:
    Oct 10, 2011
    #7
    was the link you provided taken down? Im seeing an error when going to it -
     
  8. jaymdubbs macrumors newbie

    Joined:
    Oct 10, 2011
    #8
    nevermind - saw i had use a different log in in my router in order to turn off the firewall. once i disabled it, pure magic. FINALLY, my macbook and mini run like they should

    appreciate pointing me in the direction time warner AND apple couldn't.......turn off the firewall!!!
     

Share This Page