Can pwnagetool unlock upgraded v2.0 iphones?

Discussion in 'Jailbreaks and iOS Hacks' started by BrentMannering, Jul 22, 2008.

  1. BrentMannering macrumors newbie

    Joined:
    Jul 22, 2008
    #1
    I made the mistake of letting iTunes update my iPhone(2G) to version 2.0 before any hacks were released.
    Now I am wondering if pwnageTool will be able to JB, Unlock and Activate my phone.
    The reason for this question is I have read alot about pwange tool needing bootloader 4.6 and so on, and I was of the understanding that v2.0 from apple used bootloader 4.9, which i would imagine would now be on my iphone.

    Note: the phone was previously Ziphoned in v1.1.4... may throw a different spin on things.
     
  2. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #2
    Yes. In fact, one of the things you have to do before using pwnage2.0 is that you upgrade to firmware 2.0. Read the tutorial on hackthatiphone, it lays out everything pretty clearly.
     
  3. BrentMannering thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #3
    Excellent, Thank you! That must be the only tutorial that stats to upgrade first, ever other I found says to disconnect before and blah blah. Sweet off to hack my iPhone, Thanks again!
     
  4. megamanbnmaster macrumors 6502

    Joined:
    Jan 26, 2008
    #4
    uhh... no u dont.
    i upgraded my iphone when it was on firmware 1.1.4 (JB and unlocked)

    u just have to stick it into dfu recovery mode and recover from the modifed ipsw file.
     
  5. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #5

    You are right. I stand corrected, I followed the hackthatiphone tutorial though and it did recommend going to 2.0 before running pwnage.
     

Share This Page