Can see GoGo network...can't connect to GoGo website

PaperQueen

macrumors 6502
Original poster
I'm hoping someone out there has figured this out since nothing I can find online has a solution.....

Was on a Delta flight (DL1987 MSP>SAN) yesterday, unable to access GoGo's login page. I could see the GoGo network, was IN the network, but my browser wouldn't redirect to the GoGo site. Tried Safari, Firefox, and Chrome...no luck.... The two gentleman in my row were able to log in successfully on their iPad and iPhone, so GoGo access was definitely there.

I'm stumped. This is the same laptop I've used with GoGo nearing 100 times since the service launched, including several in the past month.

Anyone else have a clue as to what's going on? A couple of internet searches have turned up the exact same problem with other Mac users in other forums, but each says that when they call GoGo, they get no help diagnosing the problem.

Of course, the only way to test this stuff is to be on a plane.... :::sigh:::

Thanks in advance, folks!
 

showcaller

macrumors newbie
Mar 31, 2011
1
0
Try this

I've had this problem with GOGO and then had the same problem trying to connect to the T_Mobile wireless network.

Try this:

Click on the Airport icon and open network preferences
Delete the Airport icon in the left box by clicking the - sign at the bottom.
Click on Advanced on the right
Click on the TCP/IP tab
Click on the "renew DHCP lease" buttonClick "OK"
click on the + symbol to add airport back in

This took care of my problem with T-Mobile's network and I assume (when I get on the plane) that I will be able to connect to GOGO's network.

Good luck.
 

TexasTanker

macrumors newbie
Mar 11, 2014
1
0
Where you able to fix it?

I am having the same issue and was wondering if you were able to fix it? If so how?
 

Macsammy

macrumors newbie
Apr 29, 2016
1
0
Try this

I've had this problem with GOGO and then had the same problem trying to connect to the T_Mobile wireless network.

Try this:

Click on the Airport icon and open network preferences
Delete the Airport icon in the left box by clicking the - sign at the bottom.
Click on Advanced on the right
Click on the TCP/IP tab
Click on the "renew DHCP lease" buttonClick "OK"
click on the + symbol to add airport back in

This took care of my problem with T-Mobile's network and I assume (when I get on the plane) that I will be able to connect to GOGO's network.

Good luck.

Way to go. That worked perfectly for me! That saved me!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.