Can somebody help me with weDict ?

Discussion in 'iPod touch Hacks' started by patricklanc, Nov 5, 2007.

  1. patricklanc macrumors newbie

    Joined:
    Nov 5, 2007
    #1
    Hi everybody,

    I have some problem with my weDict. I have already put weDict.app through SFTP into my iTouch, and actived it by SSH. I also put dictionaries into itouch too. However, no matter which word I cheched, it always showed "not found" or it just shut down. How can I fix it? I have tried install weDict for many times (just delete from itouch and put it again). The other applications work well with this method. Can anyone help me? It bothers me for a long time. Many thanks.
     
  2. shotgunfool macrumors newbie

    Joined:
    Nov 3, 2007
    #2


    Ive found a way round your problem have you only installed wedict? if you have then there is your problem go to installer and open dictonaries and install WordNet Version 2.4.2 its 10mb so be patient then you will have a lot of words in your pocket =))


    Shotgunfool
     
  3. patricklanc thread starter macrumors newbie

    Joined:
    Nov 5, 2007
    #3
    Thanks for replying. However, I did not see any WordNet in my installer, neither did the "dictionaries". So I tried to install weDict again, and see the message from terminal when the things went wrong. Here is the message before the weDict shut down.

    007-11-06 00:42:11.320 weDict[36:d03] *** Uncaught exception: <NSInvalidArgumentException> *** -[NSCFString stringByAppendingString:]: nil argument
    zsh: trace trap /Applications/weDict.app/weDict

    Can anyone know what's wrong with this?
     
  4. rworne macrumors 6502

    Joined:
    Jul 23, 2002
    #4
    I had issues with WeDict and I found that if you install any dictionaries before installing WeDict you screw it up. In my case the installer keeps failing.

    I needed to uninstall all the dictionaries, install WeDict, then install the dictionaries I wanted.

    So, I don't know if the above is any help, but that's what I had to do to get it running properly on my iPod.
     
  5. tongxinshe macrumors 6502a

    Joined:
    Feb 24, 2008
    #5
    Two things to do

    First, after launching weDict, click the little "i" icon to the top-right corner several times, till it rotate to show you available dictionaries, click those you want to activate, then click "Done".

    If the above doesn't solve your problem, then you need to SSH to your iPod Touch, delete the file /var/root/Library/weDict, and create a directory of the same name. Then, in Installer.app. uninstall all of the dictionaries you have installed, and install them back, then follow the steps mentioned in the first paragraph.
     
  6. larzters macrumors newbie

    Joined:
    Apr 14, 2008
    #6
    wedict dictionaries found!

    try doing this..uninstall ur wedict first including dictionaries you've installed previously then open ur ibrickr to create a forlder (/var/mobile/Library/weDict/)
    inspect if any files still placed in the root related to wedict then delete it!
    (for ex. applications/
    library/
    system/
    bin/
    ...
    ...
    var/
    weDictFix113.sh** (delete this one)
    then refresh you iphone and go back to your installer
    install wedict after that install all ur prospedted dictionaries
    see if your local dictionaries already found by wedict sofware by clicking the "i" then cross ur finger...:)

    i've done this work around when i first unlock my iphone using iplus.20b
    Hope i can help you all with this
     
  7. igmolinav macrumors 65816

    Joined:
    Aug 15, 2005
    #7
    Hi,

    I have an ibook G4. This answer:

    /var/mobile/Library/weDict/

    doesn't tell me much because I think we can't do that with the ibook G4.

    Also, I don't know how to copy all these tarball files to my iphone, or if I should.

    I have already "extracted" the .dict files from the .dz files, and with the .idx files, I have tried to transfer them from my ibook's desktop to my itunes library with the hope they may be uploaded to my iphone. This attempt, however, was without any success.

    By the way, I also have WeDict and WordNet in my iphone.

    What am I not doing right ??? Please let me know how could I upload these dictionaries.
     
  8. igmolinav macrumors 65816

    Joined:
    Aug 15, 2005
    #8
    P.S. What I meant to say is that perhaps, all previous answers were aimed mainly at PC users, and it is not so helpful for me as a mac user.

    Thank you again,

    igmolinav.
     
  9. tongxinshe macrumors 6502a

    Joined:
    Feb 24, 2008
    #9
    You need to learn some unix commands

    The above instruction works. You don't understand it correctly because you don't know about "ssh", UNIX commands and UNIX file path. That's too big a topic to discuss here. Go get a friend who knows a little bit unix commands to help you.
     
  10. tongxinshe macrumors 6502a

    Joined:
    Feb 24, 2008
    #10
    Be more specifically, at the time you used iTunes.app, you should have been using Terminal.app instead.
     

Share This Page