Can someone please just clarify.. (1.1.2 OTB)

Discussion in 'Jailbreaks and iOS Hacks' started by AlBDamned, Dec 2, 2007.

  1. AlBDamned macrumors 68030

    AlBDamned

    Joined:
    Mar 14, 2005
    #1
    If I ask a friend in the US to buy and send me an iPhone (to Australia) and it comes with 1.1.2 firmware, can I or can I not downgrade to 1.1.1 and unlock it?

    I'm so close to pulling the trigger but there seem to be lots of conflicting reports on the web that are not easily decipherable. :confused:

    Cheers

    Edit: I think I've found the answer to my question. Seems to be impossible at the moment.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    1.1.2: out of box, cannot be software sim-unlocked.
    Includes all iPhones made after early November.

    You can use it as iPod touch. Or wait.
     
  3. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #3
    ??? Really? He can't downgrade to 1.0.2, reduce the modem firmware, then up to 1.1.1 & 1.1.2? I thought it was doable. ??
     
  4. Luis macrumors 65816

    Luis

    Joined:
    Jul 19, 2006
    Location:
    Costa Rica
    #4

    Not possible. You can downgrade the firmware, but not the Bootloader, which is the real problem.
     
  5. Lycanthrope macrumors 6502a

    Lycanthrope

    Joined:
    Nov 1, 2005
    Location:
    Brussels, Belgium, Europe
    #5
    I'm in the same position, I could buy a €750 unlocked phone here in Europe via France Orange but can't justify the cost. On the other hand, a phone from the US today costs €280ish with the current exchange rate so it's a very attractive option even though it carries some risk.

    I suppose it's a matter of time before this will be possible though.

    The hardware solutions such as Turbo SIM work with the 1.1.2 OTB though??

    Does anyone know if it's necessary to activate the phone via AT&T in the US or can this be done in Europe?
     
  6. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #6
    Cold, hard, sad facts.

    They will in all likelihood need the next revision of firmware to be released before they are able to SIM unlock retail boxed 1.1.2 firmware phones.
     
  7. Lycanthrope macrumors 6502a

    Lycanthrope

    Joined:
    Nov 1, 2005
    Location:
    Brussels, Belgium, Europe
    #7
    Sorry to sound dumb (but I am), in what way will a revision to 1.1.3 change anything or, is it just in the hope that Apple leaves a loophole for hackers to utilise?
     
  8. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #8
    I don't know why they need 1.1.3 since I'm not an uber-iphone-h4x0r. All I know is that that's what they say they need.
     
  9. Lycanthrope macrumors 6502a

    Lycanthrope

    Joined:
    Nov 1, 2005
    Location:
    Brussels, Belgium, Europe
    #9
    OK, thanks anyway :)

    But the 1.1.2's should work with a Turbo SIM though?
     
  10. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #10
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/3B48b Safari/419.3)

    I think it's something to do with changes to the bootloader in 1.1.2 that mean you need the current version and a newer one to be able to modify it
     

Share This Page