Can`t find my external Hard drive

Discussion in 'Mac Apps and Mac App Store' started by Mac1212, May 19, 2009.

  1. Mac1212 macrumors member

    Mar 3, 2009
    I dont know if this is the right place to post this post, but i dont know where else to post it.

    I have and Maxtor touch one III.

    I have installed the software update for mac OS, but it still wont find my hard drive. ITs not mac format, but its FAT32 and i heard that worked aswell.

    I can try to fromat it to mac format, but there is still some data on it that i want.
  2. Achiever macrumors 6502


    Jan 23, 2008
    The Mac should find and display the drive..unless the preferences aren't set to show it.

    In the finder, open the preferences. It usually allows you to select/deselect what icons to display on the desktop. It is possible that the Mac is reading the drive, but the preferences are set so that you don't see an icon for it. That might be a place to start.
  3. Mac1212 thread starter macrumors member

    Mar 3, 2009
    It is set to show everything. is it right that FAT32 is supported?
  4. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    Have you looked into Disk Utility (Applications > Disk Utility) if your drive is even recognized and just not mounted?

    You can also try an SMC reset. (Google: SMC reset "your machine - ibook, imac, macbook", it will turn up Apple support documents on how to do that.)


    PS: FAT 32 is read and write supported, NTFS is only read supported. But Mac OS should show it anyway.
  5. Mac1212 thread starter macrumors member

    Mar 3, 2009
    it doesnt seem to show there
  6. Mac1212 thread starter macrumors member

    Mar 3, 2009
    Problem solved, or its not really solve, but now it just randomly poped up.. thanks any way for all the answers
  7. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    If it occurs again, try the SMC reset the next time. It helped me to recognize my FW800 drives on my iMac and MBP.
  8. TreeLogic macrumors newbie

    Jan 3, 2011
    Hope this helps...

    I have been struggling with this same issue and finally can see my external hard drive again on my iMac. Here's what happened:

    1) Rearranged my office and unplugged computer and everything attached. All was unplugged for a few days.
    2) Reconnected everything as best I knew how...power cords don't always have a label for the device they power.
    3) Struggled for weeks with support (Western Digital and Apple).

    After looking at Western Digital's support site, I noticed it gave the specs on what power cord my hard drive should use. Well, I had the router-cord in the hard drive, and the hard-drive-cord in the router. The router worked great, and the hard drive appeared to be working (the light was on) but didn't mount. The specs labeled on the plug of each power cord led me to the discovery. Everything thing is fine now and I might owe the support sites some apologies. But seriously, label your power cords people (Western Digital and Belkin)! You label every freakin thing else!

    Hope it solves at least some of your issues. I cant tell you how many drivers I've downloaded and workarounds I've tried.
  9. ronrontan macrumors newbie

    Jul 1, 2011
    Can`t find my external Hard drive Reply to Thread

    I had the same problem and solved it: the cable connector of External hard drives normally have TWO USB plugs. Try plugging both of them into your Mac. This solved my problem.
  10. garycurtis macrumors 6502

    Sep 15, 2010
    Los Angeles & Northern California
    That happens to me when I fail to 'eject' my ext. HD prior to restarting or shutting down. The icon simply doesn't appear on the desktop.

    I usually run Disk Warrior on the drive and everything returns to normal. I'm connected by Firewire, incidentally.

Share This Page