Can the 13" Macbook Pro run 1080p mkv files smoothly?

Discussion in 'MacBook Pro' started by kuato, Jul 29, 2010.

  1. kuato macrumors member

    Joined:
    Jun 10, 2009
    #1
    Basically I want to watch high definition videos on my 42" hdtv so I bought the mini display port to hdmi adapter. When I play the videos with VLC I notice choppiness when things move too fast across the screen. Is this a limitation of the hardware (the integrated GPU?) Anyway I can perhaps smooth it out?

    Thanks!
     
  2. GabooN macrumors regular

    Joined:
    Mar 31, 2008
    Location:
    Windsor, Ontario
    #2
    I have no problems watching MKV on my 2009 13 MBP on my 40" Samsung TV. I use Plex though, but I have opened the files in VLC for previewing. Haven't watched enough in VLC to notice choppiness. No problems with Plex though.

    Another thought, is your TV 120Hz? If so, is dejudder or any of those settings turned up? May be causing the 'fastness' you describe.
     
  3. aeboi macrumors 65816

    aeboi

    Joined:
    Sep 20, 2009
    Location:
    Bay Area
    #3
    I just watched star trek in 1080p using VLC on my flat screen, smooth

    like butta
     
  4. kuato thread starter macrumors member

    Joined:
    Jun 10, 2009
    #4
    my tv is 120htz. im not sure what you mean by judder. i will try using plex though. after googling this issue i have heard it mentioned numerous times.

    EDIT: I turned up judder reduction all the way and it still occurs. tried playing videos with plex and its still occurring. maybe im being too anal. its not that bad. just not as smooth as my cable. shouldnt be the tv (its a 42" samsung LCD with 120Hz)
     
  5. FnuGk macrumors regular

    Joined:
    Aug 6, 2009
    #5
    turn 120hz off and see if that fixes it. Knowing anything you would know running with higher hz bring just as many problems as it tries to solve :)
     
  6. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #6
    One day we'll have silky smooth 1080p.

    Until then, we'll have to just enjoy the slightly less good quality but buttery smooth 1080i.
     
  7. demonsavatar macrumors regular

    Joined:
    Jun 26, 2010
    #7
    In fact it can even play TWO 1080p movies smoothly. :p
     
  8. kny3twalker macrumors 65816

    kny3twalker

    Joined:
    Oct 25, 2009
    #8
    Have you considered that the file maybe the problem? Or does this happen with every 1080p movie?
     
  9. Dsync macrumors member

    Joined:
    Jul 26, 2010
    Location:
    USA
    #9
    I wish I could tell you how to fix the issue, but I can't. However, I can tell you that the 13" MBP CAN do what you are trying to do! I use mine for watching 1080 content on my 50" Samsung quite often. It might be your HDMI adapter? I use apple's DVI one and then a DVI to HDMI cable (not adapter) to go to my screen. If I were you, I would stay away from VLC! That application is horrible for this use!
     
  10. phixiuz macrumors regular

    Joined:
    Aug 25, 2009
    #10
    VLC indeed often results in choppy playback with high-bitrate 1080p MKV's. You should try Movist or Plex like said before, then your problems should be gone. Unless your MKV's have an extremely high-bitrate, but I haven't had any choppy playback yet so far with Movist nor Plex.

    Edit: The choppiness you describe could also be related to your TV, could be due to the fact that it doesn't support 24p well enough, I've got the same problem with my 2 year old Samsung LCD, you indeed mostly notice it in fast moving scenes.
     
  11. sup3r1or macrumors regular

    Joined:
    Jun 24, 2010
    Location:
    Manchester, UK
    #11
    I have the same problem, tried different players still the same result and VLC being the worst of 3 when it comes to MKV Files.

    Tried Avatar, Fast Furious 4, Batman Dark Knight all in 1080p 20GB files. Laggs all the way, my process monitor shows CPU load on average 90-150% most of the time above 100. Movies move like slide show, then smoothly for 30 secs then slide show again.
     
  12. Cave Man macrumors 604

    Cave Man

    #12
    It's (mostly) not a hardware issue. Try MPlayer Extended. Do you know what the video and audio codecs are of the files you're trying to play?
     
  13. falterego macrumors 6502

    falterego

    Joined:
    Dec 28, 2008
    Location:
    Southern California
    #13
    I'm not sure what the requirement is, I have several codec packs installed, but my MKV files play perfectly smooth in Quicktime. I just watched part of the hangover in 1080p last night and didn't see any problems. I'm also using the Mini DP to HDMI adapter then an el-cheapo $4 HDMI cable to my LCD.
     
  14. menomano macrumors member

    Joined:
    Feb 23, 2009
    Location:
    usa
    #14
    mkv is the container, you can't conclude what plays smooth or not without mentioning what codec was used inside. That Star Trek could be x264 which is optimized and plays nicely, the other guy's mkv may have something else inside.
     
  15. falterego macrumors 6502

    falterego

    Joined:
    Dec 28, 2008
    Location:
    Southern California
    #15
    Ah, so like an AVI. I've always hated that container/encoding business. Just give me everything in .mp4 so I can load it on my iPod and stream it to my Xbox 360.
     
  16. Cave Man macrumors 604

    Cave Man

    #16
    MP4 (and M4V) is also a container. They're called "containers" because they can contain many things. For example, I have a Blu-ray rip (m2ts container) that has the following items:

    1080p video in h.264
    Audio track 1: True-HD English
    Audio track 2: AC3 Spanish
    Audio track 3: AC3 French
    Subtitle track 1: English
    Subtitle track 2: Spanish
    Subtitle track 3: French

    AVI is just another container and doesn't tell what's inside it.
     
  17. sup3r1or macrumors regular

    Joined:
    Jun 24, 2010
    Location:
    Manchester, UK
    #17


    Can I ask how do you manage to play MKV files in QuickTime? I have Perian installed but it doest have HD codecs so I really want to find one.
     
  18. Alvi macrumors 65816

    Alvi

    Joined:
    Oct 31, 2008
    Location:
    Mars
    #18
    Mine does it perfectly and It's not even the newest 13" Model, I think even the MacBook Air can do it but it gets hot
     
  19. justaregularjoe macrumors 6502

    Joined:
    Nov 28, 2008
    #19
    And fry an egg at the same time. :rolleyes:
     
  20. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #20
    - And people wonder why we buy Apple hardware...
     
  21. justaregularjoe macrumors 6502

    Joined:
    Nov 28, 2008
    #21
    lol multitasking in the extreme.

    Whiter than sour cream.

    Sorry, I had to.
     
  22. GabooN macrumors regular

    Joined:
    Mar 31, 2008
    Location:
    Windsor, Ontario
    #22
    My tv, when set to the 'pc' input, turns off the smooth motion and the dejudder settings and displays at 60hz. It is a samsung and I think it is just under "120Hz" and "Smooth Motion" or something along those lines. The speed up you are talking about sounds like a combination of those two settings. Try disabling them (instead of turning them up) and see if you feel it has improved.

    What TV is it that you are connecting it to?
     
  23. kuato thread starter macrumors member

    Joined:
    Jun 10, 2009
    #23
    its a 42" Samsung LCD. Its got a feature called Auto Motion Plus 120Hz. I've been messing around with the 2 settings, blur reduction and judder reduction. I can mess with them individually or use the pre-settings Clear, Standard, or Smooth. When I turn it off I think I get the best results. It's odd though. Why would turning it off improve the playback? You say you get good results with the PC input. Is there any difference going VGA instead of HDMI?

    Thanks for all the replies!!
     
  24. Calculon macrumors newbie

    Calculon

    Joined:
    Mar 26, 2011
    Location:
    The Future
    #24
    This worked for me

    I had the same issue.
    I found that changing a preference in VLC provided smooth playback.
    This solution assists the playback of any movie files played from hard disk.

    Go to Preferences (⌘,) click All preferences in the bottom left corner.
    - select Input/Codecs, then within that, Access modules, and finally within that, File.
    - change the Caching value (ms) to 800.
     

    Attached Files:

Share This Page