can the files be saved?

Discussion in 'macOS' started by BugsBunny, Mar 5, 2009.

  1. BugsBunny macrumors member

    Joined:
    Jun 16, 2007
    #1
    so guys i posted earlier about how my computer was screwing up...finder doesn't work, i can't open to view any folder, etc....it is definitely a hardware problem, i hear things click inside the computer every once in a while...i tried running time machine on a brand new drive, and it got thru like 700MB/100GB and then failed.

    and to be honest, i'm really stupid (i realize now) i've only ever used my (non-time machine) external hard drive to offload movies and tv shows that i download. i don't care if i have to get a new computer, i've actually been considering it for a few months, but will someone at an apple store be able to save my pictures (most important to me is the pictures, everything else i can get again), music, etc.? it's really weird because the OS loads fine and looks good on the surface until you try to run anything...and in the menu bar spotlight is constantly indexing. you don't know how heart breaking it was to get excited that time machine was gonna work and save me, only to see it fail before getting 1% through :( :( :(

    sorry for posting again but i'm freaking out and just want peace of mind that my things can be saved by an expert who might be able to take it apart, fix the hardware problem, then get it off. is that going to be possible?
     
  2. BugsBunny thread starter macrumors member

    Joined:
    Jun 16, 2007
    #2
    maybe its worth mentioning too, the files that i can see on my desktop, they show me the little preview thing, so like i have some .pdfs and i can see that the first page is the icon, or a couple pictures i can see the picture in micro, so i know the files are still there, the OS just can't load them for some reason.
     
  3. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
  4. LeeTom macrumors 68000

    LeeTom

    Joined:
    May 31, 2004
    #4
    Boot from the Install DVD (put the cd in the drive, restart, and when the chime goes hold down the C key), and go like you're going to do a reinstall.

    As soon as you see the menubar at the top, go up to Utilities and down to Disk Utility. Choose your hard drive on the left, and click the Repair Disk button.
    Do it a second time for good measure after it's done. Also do the Repair Permissions button.

    Then, quit Disk Utility. Open Password Reset Utility. Don't reset your password, but DO Repair your Home Folder permissions.

    Reboot.
    Run time machine onto the drive again. Does it work now?
     
  5. BugsBunny thread starter macrumors member

    Joined:
    Jun 16, 2007
    #5
    hi and thanks for your help!

    what does that mean? how do i do that? i can't open finder to move my files into an external, so if you mean reinstalling the OS i assume that won't be any good, right? as in, everything's gone when you reinstall, right?

    i've tried loading into safe mode, but when i'm holding shift after the chime the rotating gear never comes up, even after like 5 minutes. this is really frustrating because this is my first apple, and though i haven't had a problem in 2 years, i always used to know how to fix PCs (or at least give it a try). any help you give me in learning how to fix this is so helpful and thanks a million. i'm almost in tears over losing all this stuff -- but it's all there, so I can't imagine its gone, my computer is just having issues.
     
  6. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #6
    Archive and install DOES reinstall Mac OS X.
    It DOES NOT erase the hard drive, like a Windows PC would. Just make sure to follow what's in bold below, and you'll be all set.

    Info from Apple's knowledge base article:
     
  7. BugsBunny thread starter macrumors member

    Joined:
    Jun 16, 2007
    #7
    i'm doing this now. if it works (or for that matter, anything that eventually comes out of this thread works), and i'm not joking, i will eagerly donate $20 to a charity of your choice - you'll have saved me much more than that anyway!
     
  8. BugsBunny thread starter macrumors member

    Joined:
    Jun 16, 2007
    #8
    it didn't work

    the archive and install failed, saying "the following install step failed: run postinstall script for Essentials. Contact the software manufacturer for assistance."

    any ideas what that means?

    edit: i'm now trying LeeTom's disk repair series of suggestions.
     

Share This Page