Can u bypass 4.2 requirement?

Discussion in 'Jailbreaks and iOS Hacks' started by California King, Dec 18, 2010.

  1. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    I want to get Tour Wrist on the App store, but it says you need 4.2 to download it. Any way around this? I have a iPhone 4 so I don't think I can upgrade to 4.2 yet, w/o losing my jailbreak.

    Anyone know why this app has this requirement?
     
  2. tourwrist macrumors newbie

    Joined:
    Dec 18, 2010
    #3
    Why Tour Wrist requires 4.2

    California King:

    Thanks for trying to download the app. In our ongoing effort to optimize our app's performance, we found that iOS apps prior to 4.2 suffered from a slow memory leak when accessing the integrated map components - something Tour Wrist uses extensively. So when we discovered that 4.2 had addressed this issue, we were faced with a difficult decision; adopt the latest version of the OS a bit early and thus slow our adoption, or continue to allow for a gradual leak that eventually leads to the app crashing in most devices.

    I wish we had a better answer for you, but I'm sure your options will improve in the not-too-distant future. Please check us out when your options do improve.
     

Share This Page