Can you tell time machine not to automount a network share?

Discussion in 'macOS' started by vrillusions, Dec 3, 2007.

  1. vrillusions macrumors regular

    vrillusions

    Joined:
    Jul 8, 2007
    Location:
    Cleveland, Ohio, US
    #1
    I have been testing time machine backups for the last few days and I'm far from impressed. Current issue i'm having is the server (Leopard Server) is accessible from the internet. This means the network share is accessible from the internet. So when I'm at home the laptop wants to backup. Problem with that is the current sparseimage is about 20gb. Plus my home connection isn't all that reliable at times and you get the idea.

    My first thought was to simply unmount the Backups share thinking if it can't see the share it won't back up. Well leopard is too smart for its own good and happily mounts the Backups share and tries to backup.

    Next thought was that it may be "location aware" so even though both my home and work networks just use DHCP i set me up a work location, enabled time machine. Switched to home location and disabled time machine. Went back to work location and it was still disabled.

    Right now the only solution I have come up with is manually going into system preferences and turning off time machine when i'm not in the office, then turning it back on when I return to the office. I'm sure this can all be applescriptable and I plan on looking into that next (basically a script that sees if location is "Work" then turn time machine on, if not then turn time machine off). But there should be some easier way. I was hoping for a defaults write autoMountDrive no or something to that effect. Anyone else come up with a solution?
     
  2. mmaciver macrumors newbie

    Joined:
    Jun 27, 2009
    #2
    Automounting a network share

    I have precisely the same problem. Set up a network share for Time Machine at the office, where it is connected to a large drive via gigabit ethernet. At home on my wireless network, I don't want my limited bandwidth killed by automounting and backing up over my cable modem. I haven't been able to find a solution other than manually switching off Time Machine.
     
  3. mmaciver macrumors newbie

    Joined:
    Jun 27, 2009
    #3

Share This Page