Can you use a UK sim in the US iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by rph105, Jan 11, 2008.

  1. rph105 macrumors 6502

    rph105

    Joined:
    Jul 21, 2007
    #1
    Bought a US iPhone, I've jailbroken it on the 1.1.1 firmware, can I unlock it so I can use my I'm o2 pay as you go sim, and if there's any other method but the turbosim method, I don't feel to pay £99 on top to unlock my iPhone
     
  2. jawad7 macrumors member

    Joined:
    Nov 8, 2003
    #2
    i'm in the same boat as you. I'm going to the US next week and want to buy an iPhone but not sure if i can unlock to work with UK sims. Anyone?
     
  3. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #3
    well, you should have done more research before buying the iphone then
    THERE IS NO SOFTWARE UNLOCK FOR 1.1.2 IPHONES
    also, the phone will never work unless you upgrade back to 1.1.2
    you need to use a *sim in order to unlock it, in a few weeks this may be a different story though...
    only by using hardware unlocks at the moment
     
  4. rph105 thread starter macrumors 6502

    rph105

    Joined:
    Jul 21, 2007
    #4
    NAH but see, i bought my iphone and it was unlocked my o2 pay as you go sim worked, my stupid bro updated it on itunes causing the sim to be unreadable, so I dont believe i need a turbo sim, because it didnt come with one, i plugged in my sim and it worked fine, so there must be a way, someone must know?
     
  5. blaster_boy macrumors 6502

    blaster_boy

    Joined:
    Jan 31, 2004
    Location:
    Belgium
    #5
    An iphone with originally 1.1.1 firmware on it but which was upgraded to 1.1.2 can be unlocked.

    You need to restore your phone to 1.1.1 and do an unlock again using AnySim. Worked for me. You can then even upgrade to 1.1.2 using oktoprep.
     
  6. Corvillus macrumors member

    Joined:
    Jan 12, 2008
    #6
    If the iPhone was UPGRADED to 1.1.2 (meaning it still has 3.9 bootloader), you can re-unlock it by downgrading to 1.1.1, jailbreaking with jailbreakme.com, installing OktoPrep, upgrading to 1.1.2, using touchfree jailbreak, installing anySIM 1.2.1u, putting iPhone in airplane mode, and running anySIM 1.2.1u while the iPhone is in airplane mode (the airplane mode part is extremely important, you WILL brick the phone if you attempt an unlock on 1.1.2 without airplane mode).

    If the phone came with 1.1.2, you're SOL though...as those phones have the 4.6 bootloader, which blocks all current unlocks. Wait till a week or 2 after 1.1.3 firmware launch, and see what happens (and DON'T update in the meantime).
     

Share This Page