Cancelled AT&T unlimited text message plan = Texts no longer work?

Discussion in 'iPhone' started by converge, Oct 17, 2011.

  1. converge macrumors member

    Joined:
    Aug 4, 2009
    #1
    One of the first things I did after upgrading to iOS 5 was cancel my unlimited text message plan. I used AT&T's "manage features" option on their website to do this. However, over the weekend, I noticed I was not getting any responses from the text messages I was sending to people. I figured out that I was not able to send or receive standard text messages. But I was able to send and receive iMessages.

    Apparently, people are having an issue with iOS 5 because they have too many text messages and going over a now-imposed limit. However, when I upgraded, I restored as a new phone. I didn't have any text messages to start with! So I don't think that's my issue.

    After restoring again to no avail, I figured out the solution. I went back on AT&T's website and re-enabled the $20 unlimited text message plan. Miraculously I was able to now send and receive text messages!

    What is the deal with this? Is AT&T disabling text messages if you don't have a text message plan but are using iMessages instead?
     
  2. ohio.emt macrumors 6502a

    Joined:
    Jul 18, 2008
    Location:
    Ohio
    #2
    Are you sure you didn't click no text messages instead of the pay as you go option by mistake. I had a friend do this my mistake before.
     
  3. Vertigo50 macrumors 65816

    Vertigo50

    Joined:
    Apr 11, 2007
    #3
    On your iPhone, go to Settings - Messages.

    Make sure "Send As SMS" is set to ON and not to OFF.
     
  4. Chaos123x macrumors 68000

    Joined:
    Jul 8, 2008
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Most of my friends and relatives have iPhones sucks that AT&T only offers unlimited or pay as you go. iMessage works so much faster then SMS and its free.
     

Share This Page