Cannot access external hard drive

Discussion in 'Mac Basics and Help' started by happened2behere, Nov 25, 2009.

  1. happened2behere macrumors newbie

    Joined:
    Nov 25, 2009
    #1
    Hi,

    Everytime I try to click on my external hard drive it closes the window. I have two identical WD MyBook 250GB drives. Both are FAT 32 formatted. I can access one of them fine from my Macbook. The other displays its icon, but as soon as I click on it, it opens a window, then closes it again. I can access the drive via a PC.

    I purchased a replacement hard drive (LaCie mobile disk 500GB) which worked fine until I transferred the data at which point the same thing started happening with the new drive. I ran a Bit Defender scan on the hard drive and the only thing that turned up was an "Exploit.PDF-JS.Gen" file buried inside Adobe Acrobat. Bit Defender couldn't quarantine or disinfect the file so I deleted the copy of Acrobat but the drive still won't mount.
    I have a Macbook running OS X 10.4.11 and a 2 Ghz Intel processor.

    Has anyone run into this before? Any help would be appreciated.

    Cheers,
    D
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    If the drive is "Mac only" (i.e., you intend to connect it only to Macs, and never to PC's), why not use Disk Utility to re-initialize it to the Mac OS?

    - John
     

Share This Page