"Cannot access memory at address 0x4" error

Discussion in 'Mac Programming' started by okskpark, May 27, 2009.

  1. okskpark macrumors newbie

    Jul 26, 2008
    Seoul, South Korea

    I have the error message.
    So I tried a lot of ways. Even I reinstalled XCode.

    But, it still appeared. So I created new project (coredata document based) and I just build and debug the project. (I didn't do anything.)

    I can see the same error message.

    What the hell is this?

    the error message is like this
    These three lines are always same.

  2. jpyc7 macrumors 6502

    Mar 8, 2009
    Denver, CO
    Um, it looks like you incremented a NULL pointer (represented as 0) on a 32-bit machine and then tried to dereference it. You need to use your debugger to get a stack trace so you know what line in your program that this happens.

    If you're saying that you were given the source code and this happens, then you might contact the programmer about this bug. There's also the possibility that you were supposed to give some input to the program and you gave an invalid value that it doesn't handle.

Share This Page