Cannot access share after Yosemite update

Discussion in 'iMac' started by Milew23, Feb 23, 2015.

  1. Milew23 macrumors newbie

    Joined:
    Jun 27, 2013
    #1
    I just updated to Yosemite, when I am at my PC and attempt to access files from my mac, it is prompting for a username and password. I put in the only ones I use. The computer name and my password. It didn't do this prior to the update. What password would it be asing for? My apple ID? I do not use a password to get into the computer and the one i use when prompted for updates isn't working . What changed? And where do I find my computer info (name, etc)

    It says in the sharing area (on the mac) that "windows can access this computer at "milew". Ok, there is that,then if I installing something, a box pops up with my full name, I enter a password and done adn done. Why, all of the sudden am I being prompted to logi in? I am using the only two usernames and ONE password that Ihave!! Nothing has changed in the sharing settings. I never had this prior to yosemite update. How exactly (screens shots if possible) is the sharing to be set up in order to share you mac? Again, nothing changed but for some reason it isn't taking my credentials and I am not on a domain.So what should the password be? he one I use when downloading? My apple id password?ids the username jsut the computer name? Is the log in like

    computer name
    password

    or

    username\computername
    password?


    Why!!!!!?? hhaha any help, pleas
     
  2. Milew23 thread starter macrumors newbie

    Joined:
    Jun 27, 2013
    #2
    I have posted this in like 4 forums. Not one response. No one has had this happen or can give any insight as to what I maybe doing wrong?
     
  3. marzer macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #3
    It likely is due to the fact that with Yosemite, OS X is using SMB 3 now. Mavericks was still SMB 2. SMB is the Windows file sharing protocol that allows Windows and OS X to file share over a network.

    When you get a password prompt on the windows machine trying to access the OS x machine, use a username and password of an account on the OS x machine. If you don't have a password set for the OS x account, that could be a problem. As SMB gets more secure, it may not work with unsecured accounts. You might need to set a password for your OS x account.
     
  4. Milew23 thread starter macrumors newbie

    Joined:
    Jun 27, 2013
    #4
    You mean, set a password so that when I turn on the mac, it prompts for one? It doesn't now, but it does if I am making changes, etc. And my computer name is "milew" it says you can connect using milew.local.

    I have tried milew and my password
    my full name (which is a user account)
    What else? I am not on a domain
     
  5. marzer macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #5
    For starters, to authenticate using file sharing you want to use your user account name and password. Not the machine name and password. If you are trying the user account name and password and it's still not working verify the permissions. On the host machine, OS X in this case, make sure the folder location has permission to be read or written (whatever the preference) in file sharing under the Sharing preference pane. And make sure the permissions are set for the user account you are using for authentication.
     

Share This Page