Cannot access Shared folder from Windows

Discussion in 'Mac OS X Lion (10.7)' started by madman555, Jul 22, 2011.

  1. madman555 macrumors member

    Joined:
    Feb 20, 2009
    #1
    Hi all,

    I'm sharing my Public folder on my iMac. I have file sharing enabled, both with afp and smb. I have the "Allow guests to connect to shared folders" enabled on the guest account. Previously when I was running SL, I could access the shared folder from my Vista computer by typing \\192.168.20.120 (iMac's IP address). A box would then pop up prompting for my user name and password. All I had to do was enter "guest" for the user name and I was in. After installing Lion, whenever I enter "guest", it tells me incorrect password. When I browse my network on the Vista computer, I see the iMac, I just can't connect and authenticate.

    Oh, I also have a shared folder on my Vista computer and the iMac has no problems connecting to it. Does anyone have any idea what I can do so that my Vista computer and access my shared folders on my iMac? Thanks!
     
  2. madman555 thread starter macrumors member

    Joined:
    Feb 20, 2009
    #2
    I found a solution:

    I created a new user account called "share" and set the new account to "Sharing Only". Left the password field blank too. When I went to connect to my shared folder on my Mac from Vista, I just typed "share" instead of "guest" and it worked. Not sure what's wrong with the Guest account but it seems like there's a password set to it.

    One more thing, I had to go to Sharing -> File Sharing -> Options and then check the box next to the "share" account
     
  3. torna macrumors newbie

    Joined:
    Sep 1, 2011
    #3
    Thanks for your solution madman555:)

    I could create file/folder in shared folder from Windows XP by following your instruction.

    But the permission of the file/folder I created were readable and writable for the user "share" only, and other users including "everyone" have no permission.

    I could access to the file/folder from Mac OS X Lion by changing the permission of "Get Info" menu, but it was tiresome to do this everytime.

    Any idea?
     

Share This Page