Cannot activate cellular data network. Help!?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by spartan4330, Jun 26, 2010.

  1. spartan4330 macrumors newbie

    Joined:
    Jun 9, 2010
    Location:
    East bay area, CA
    #1
    My iPhone 3GS lost its ability to use its data feature (but wi-fi still worked and calling/texting) randomly about 2 days ago. I tried restarting several times, even factory restore, tried resetting network settings. I never messed with the monthly service plans so thats not the problem. I got the iPhone 4 and thought the problem mustve been something the hardware of my old phone. The iPhone 4's data feature worked fine for the day of when i got it, but randomly today stopped working. Safari won't load and anything requiring data feature is not working. Before it stopped working I saw some kind of error message saying that voicemail needed to be set up, if that helps at all.

    What should I do???

    Thanks,
    Cole
     
  2. cinico macrumors newbie

    Joined:
    Jun 26, 2010
    #2
    got the same problem. googled solutions but none of them have worked so far.
     

Share This Page